Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#6166 closed defect (fixed)

Seg fault playing videos in mythgallery

Reported by: Damian O'Sullivan <damian@…> Owned by: Isaac Richards
Priority: minor Milestone: 0.22
Component: Plugin - MythGallery Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

To repro:

Play some videos in mythgallery. This may have nothing to do with mythgallery but I only see the seg fault here.

Painter : OpenGL Theme : Blootube-wide Revision: 19804

Compile options : Options: --disable-iptv --disable-hdhomerun --disable-dbox2 --enable- xvmc-opengl --xvmc-lib=XvMCNVIDIA --enable-opengl-vsync --enable-opengl- video --enable-proc-opt --enable-libfftw3 --disable-joystick-menu --enable-silent-cc --disable-distcc --compile-type=debug

(gdb) bt #0 0xb6236bbf in ?? () from /usr/lib/libGL.so.1 #1 0xb7adee30 in ~VideoOutputXv? (this=0x8f646e0) at videoout_xv.cpp:260 #2 0xb79512c0 in NuppelVideoPlayer::OutputVideoLoop? (this=0xa66a520) at NuppelVideoPlayer?.cpp:3016 #3 0xb7951377 in NuppelVideoPlayer::kickoffOutputVideoLoop (player=0xa66a520) at NuppelVideoPlayer?.cpp:3086 #4 0xb62f750f in start_thread () from /lib/tls/i686/cmov/libpthread.so.0 #5 0xb530f7ee in clone () from /lib/tls/i686/cmov/libc.so.6

gdb.txt attached

Attachments (1)

gdb.txt (76.5 KB) - added by Damian O'Sullivan <damian@…> 11 years ago.
gdb.txt

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by Damian O'Sullivan <damian@…>

Attachment: gdb.txt added

gdb.txt

comment:1 Changed 10 years ago by stuartm

Component: MythTV - Video PlaybackPlugin - MythGallery
Milestone: unknown0.23

comment:2 Changed 10 years ago by markk

fwiw, I think the relevant areas of code have changed significantly since this ticket was created and I'd be surprised if this crash is still reproducible. The segmentation fault occurs in the VideoOutputXv? destructor and references the OpenGL libs (probably while closing the X display) - all references to OpenGL were removed from the VideoOutputXv? some time ago and all X display connections are now handled by MythXDisplay (which should be safer).

comment:3 Changed 10 years ago by sphery

Milestone: 0.230.22
Resolution: fixed
Status: newclosed
Version: unknownhead

Reporter said on IRC he can no longer reproduce the issue. Probably fixed in the changes Mark mentioned.

comment:4 Changed 10 years ago by anonymous

Hi, I am using mythubuntu with a reported SVN version of:

2009-11-11 22:39:48.381 mythfrontend version: branches/release-0-22-fixes [22594] www.mythtv.org

and I am getting this problem now. As above it is not specifically mentioned which version this was fixed? Am I still behind and not up to date with the changes mentioned?

My stacktrace (totally reproducible):

Program terminated with signal 11, Segmentation fault. #0 0x00007fae89895514 in put_pixels_clamped_mmx ()

from /usr/lib/libmythavcodec-0.22.so.0

(gdb) where #0 0x00007fae89895514 in put_pixels_clamped_mmx ()

from /usr/lib/libmythavcodec-0.22.so.0

#1 0x00007fae898f7447 in ff_simple_idct_put_mmx ()

from /usr/lib/libmythavcodec-0.22.so.0

#2 0x00007fae896fc5a4 in ff_mjpeg_decode_sos ()

from /usr/lib/libmythavcodec-0.22.so.0

#3 0x00007fae896fd181 in ff_mjpeg_decode_frame ()

from /usr/lib/libmythavcodec-0.22.so.0

#4 0x00007fae896ea6f5 in avcodec_decode_video2 ()

from /usr/lib/libmythavcodec-0.22.so.0

#5 0x00007fae896eb5f0 in avcodec_decode_video ()

from /usr/lib/libmythavcodec-0.22.so.0

#6 0x00007fae8aa3f22b in AvFormatDecoder::GetFrame?(int) ()

from /usr/lib/libmythtv-0.22.so.0

#7 0x00007fae8a9efac5 in NuppelVideoPlayer::GetFrameNormal?(int) ()

from /usr/lib/libmythtv-0.22.so.0

#8 0x00007fae8a9f00ba in NuppelVideoPlayer::GetFrame?(int, bool) ()

from /usr/lib/libmythtv-0.22.so.0

#9 0x00007fae8a9f500e in NuppelVideoPlayer::StartPlaying?(bool) ()

from /usr/lib/libmythtv-0.22.so.0

#10 0x00007fae8aa0251b in ?? () from /usr/lib/libmythtv-0.22.so.0 #11 0x00007fae85b8aa04 in start_thread (arg=<value optimized out>)

at pthread_create.c:300

---Type <return> to continue, or q <return> to quit--- #12 0x00007fae8204b7bd in clone ()

at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112

#13 0x0000000000000000 in ?? ()

comment:5 Changed 10 years ago by sphery

Can you get (and attach--please don't paste into a comment) a full backtrace with debug symbols as described in the TicketHowTo and http://www.mythtv.org/wiki/Debugging .

comment:6 Changed 10 years ago by anonymous

Yes I can do that. Eeeh, but how do you do it on a mythbuntu distro?

Do I get a SVN build at the same level and do a manual build or...? I have no problems doing that but if there is a mythbuntu way that would of course be preferable.

comment:7 Changed 10 years ago by anonymous

I tried building the same version from SVN, without LD_LIBRARY_PATH set I get a segmentation fault but symbols are limited as it then picks up the mythbuntu build. With LD_LIBRARY_PATH set to use everything from the SVN build I cannot get it to core dump. I could not find that there is any way to get a mythbuntu debug build so I think I can't resolve this or get any closer to determine what the problem is, unless you have any ideas? Let me know if you want to see the trace from the run with the mixed build...

Note: See TracTickets for help on using tickets.