Opened 11 years ago

Closed 10 years ago

#6179 closed defect (fixed)

segfault in put_h264_qpel8_h_lowpass_ssse3

Reported by: jppoet@… Owned by: Janne Grunau
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by Dibblah)

Watching H.264 recording, trapped segfault in put_h264_qpel8_h_lowpass_ssse3

Attaching BT.

Attachments (2)

put_h264_qpel8.bt (12.2 KB) - added by jppoet@… 11 years ago.
BT of segfault in put_h264_qpel8_h_lowpass_ssse3
gdb.txt (28.9 KB) - added by jppoet@… 11 years ago.
rest of BT

Download all attachments as: .zip

Change History (10)

Changed 11 years ago by jppoet@…

Attachment: put_h264_qpel8.bt added

BT of segfault in put_h264_qpel8_h_lowpass_ssse3

Changed 11 years ago by jppoet@…

Attachment: gdb.txt added

rest of BT

comment:1 Changed 11 years ago by Dibblah

Description: modified (diff)
Status: newinfoneeded_new

Does the processor you are running this on support the SSE3 instruction set?

Which branch and revision of Myth is this?

Is the issue repeatable and do you have a sample?

Does this happen with ffplay on the sample?

comment:2 Changed 11 years ago by jppoet@…

Processor: E8400 Core2

Branch: Latest trunk

Issue is not reproducible. Happens 1 out of every 4 H.264 programs I watch, and does not happen in the same place twice.

This has been happening ever since Janne's ffmpeg merge many months ago. I have not bothered to report it, because it is not reproducible. However, I decided to go ahead and post a BT in case someone can spot a problem.

comment:3 Changed 11 years ago by Dibblah

Status: infoneeded_newnew

comment:4 Changed 11 years ago by Dibblah

Owner: changed from Isaac Richards to Janne Grunau
Status: newassigned

comment:5 Changed 11 years ago by jppoet@…

Compiling with --disable-ssse3 appears to sidesteps this segfault.

comment:6 Changed 10 years ago by laga

Component: MythTV - GeneralMythTV - Video Playback
Status: assignedinfoneeded

We've had another ffmpeg resync lately. Can you try this again? If it still happens, can you try reproducing it in ffplay (from ffmpeg trunk, preferably)?

comment:7 Changed 10 years ago by jppoet@…

Does look like this is probably fixed. Been several days and no segfaults. If I get another segfault, I will open a new ticket.

comment:8 Changed 10 years ago by Dibblah

Resolution: fixed
Status: infoneededclosed
Note: See TracTickets for help on using tickets.