Opened 11 years ago

Closed 11 years ago

#6180 closed defect (fixed)

Changeset 19795 breaks Screensaver/DPMS

Reported by: Stephen <stev391@…> Owned by: Isaac Richards
Priority: major Milestone: unknown
Component: MythTV - Video Playback Version: head
Severity: high Keywords: screensaver dpms
Cc: Ticket locked: no

Description

After updating to changeset 19795 after about 10 minutes my screen goes black while watching a video. Pre-19795 versions do not show this issue.

Window Manager: fluxbox

Output using an NVidia 8400GS via composite to a CRT TV.

No changes in the mythfrontend logs (No verbose settings) between versions. Please advise which logs are required.

Attachments (1)

6180-dbg-v1.patch (1.7 KB) - added by danielk 11 years ago.
extra debugging

Download all attachments as: .zip

Change History (5)

comment:1 Changed 11 years ago by danielk

(In [19829]) Refs #6180. Refs #6162. Adds -v playback debugging to screensaver code.

If you are having problems with the screensaver/dpms please set the timeouts low and run mythfrontend with -v playback and report when the screensaver or dpms standby turns on, and which one is turning on.

Changed 11 years ago by danielk

Attachment: 6180-dbg-v1.patch added

extra debugging

comment:2 Changed 11 years ago by danielk

I've attached an extra debugging patch which will print the DPMS status after DPMS is Deactivated.

comment:3 Changed 11 years ago by Damian O'Sullivan <damian@…>

Hmm.. I applied the patch and now I don't see the issue at all! Perhaps it is the patch or perhaps its playing with -v playback

comment:4 Changed 11 years ago by danielk

Resolution: fixed
Status: newclosed

(In [19842]) Fixes #6162. Fixes #6180. XSync after all critial X11 calls in screensaver code.

The DPMS blanking problem went away for Damian when in the debugging patch that called DPMSInfo() after setting the DPMS state.. this was because the query forced X11 to sync. Adding XSync's alone was confirmed to work by jrigg.

Note: See TracTickets for help on using tickets.