Opened 11 years ago

Closed 11 years ago

#6194 closed defect (wontfix)

Backend crash memory corruption (fast)

Reported by: ian.haycox@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Myth backend crashed whilst the PC was idle. No frontend running.

New installation of Ubuntu 8.10 with MythTv? added via apt-get install.

Restarted the backend without problem and can watch TV etc.

I can provide more info or try to reproduce with guidance if requested.

Attached is the backend log with the backtrace.

Version below:

ian@ianh:~$ mythfrontend --version Please include all output in bug reports. MythTV Version : 18722 MythTV Branch : branches/release-0-21-fixes Library API : 0.21.20080304-1 Network Protocol : 40 Options compiled in:

linux profile using_oss using_alsa using_arts using_jack using_backend using_dbox2 using_dvb using_firewire using_frontend using_hdhomerun using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_opengl_vsync using_opengl_video using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmcw using_xvmc_vld using_glx_proc_addr_arb using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_libavc_5_3 using_live

ian@ianh:~$ mythbackend --version Please include all output in bug reports. MythTV Version : 18722 MythTV Branch : branches/release-0-21-fixes Library API : 0.21.20080304-1 Network Protocol : 40 Options compiled in:

linux profile using_oss using_alsa using_arts using_jack using_backend using_dbox2 using_dvb using_firewire using_frontend using_hdhomerun using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_opengl_vsync using_opengl_video using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmcw using_xvmc_vld using_glx_proc_addr_arb using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_libavc_5_3 using_live

ian@ianh:~$

ian@ianh:~$ dpkg -l | grep -i myth ii libgmyth0 1:0.7.1-1 GObject based library for accessing MythTV b ii libmyth-0.21-0 0.21.0+fixes18722-0ubuntu1 Common library code for MythTV and add-on mo ii libmyth-perl 0.21.0+fixes18722-0ubuntu1 A PERL library to access some MythTV feature ii mythtv 0.21.0+fixes18722-0ubuntu1 A personal video recorder application (clien ii mythtv-backend 0.21.0+fixes18722-0ubuntu1 A personal video recorder application (serve ii mythtv-common 0.21.0+fixes18722-0ubuntu1 A personal video recorder application (commo ii mythtv-database 0.21.0+fixes18722-0ubuntu1 A personal video recorder application (datab ii mythtv-frontend 0.21.0+fixes18722-0ubuntu1 A personal video recorder application (clien ii mythtv-theme-blootube 1:0.21.0-0ubuntu1 The Blootube MythTV theme ii mythtv-theme-blootube-osd 1:0.21.0-0ubuntu2 The Blootube MythTV OSD ii mythtv-theme-blootube-wide 1:0.21.0-0ubuntu1 The Blootube MythTV theme (widescreen) ii mythtv-theme-blootubelite-wide 1:0.21.0-0ubuntu1 The Blootube Lite MythTV theme (widescreen) ii mythtv-theme-glass-wide 0.20080908-0ubuntu2 The Glass MythTV theme (widescreen) ii mythtv-theme-gray-osd 0.21.0-0ubuntu2 The Gray-OSD MythTV Theme ii mythtv-theme-isthmus 0.21.0-0ubuntu2 The Isthmus MythTV Theme ii mythtv-theme-iulius 0.21.0-0ubuntu2 The Iulius MythTV Theme ii mythtv-theme-iulius-osd 0.21.0-0ubuntu2 The Iulius-OSD MythTV Theme ii mythtv-theme-minimalist-wide 0.21.0-0ubuntu2 The Minimalist Wide MythTV Theme ii mythtv-theme-mythbuntu 0.20080421 default MythTV theme used in Mythbuntu ii mythtv-theme-mythcenter 0.21.0-0ubuntu2 The MythCenter? MythTV Theme ii mythtv-theme-mythcenter-wide 0.21.0-0ubuntu2 The MythCenter? Wide MythTV Theme ii mythtv-theme-neon-wide 1:0.21.0-0ubuntu4 The Neon MythTV theme (widescreen) ii mythtv-theme-projectgrayhem 1:0.21.0-0ubuntu1 The Project Grayhem MythTV theme ii mythtv-theme-projectgrayhem-osd 1:0.21.0-0ubuntu2 The Project Grayhem MythTV OSD ii mythtv-theme-projectgrayhem-wide 1:0.21.0-0ubuntu2 The Project Grayhem MythTV theme (widescreen ii mythtv-theme-retro 0.21.0-0ubuntu2 The Retro MythTV Theme ii mythtv-theme-retro-osd 0.21.0-0ubuntu2 The Retro-OSD MythTV Theme ii mythtv-theme-titivillus 0.21.0-0ubuntu2 The Titivillus MythTV Theme ii mythtv-theme-titivillus-osd 0.21.0-0ubuntu2 The Titivillus-OSD MythTV Theme ii mythtv-themes 0.21.0-0ubuntu2 Additional themes metapackage for MythTV ii mythtv-transcode-utils 0.21.0+fixes18722-0ubuntu1 Utilities used for transcoding MythTV tasks ii mythweb 0.21.0+fixes18722-0ubuntu1 Web interface add-on module for MythTV ii nuvexport 0.21.0-0ubuntu2 An alternative to MythTV's inbuilt transcodi

Attachments (1)

mythbackend.log (20.7 KB) - added by ian.haycox@… 11 years ago.
mythbackend.log

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by ian.haycox@…

Attachment: mythbackend.log added

mythbackend.log

comment:1 Changed 11 years ago by sphery <mtdean@…>

Please install the Ubuntu MythTV debug package (rather than recompiling) and get a useful backtrace as described at http://www.mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2 .

comment:2 in reply to:  1 Changed 11 years ago by anonymous

Replying to sphery <mtdean@thirdcontact.com>:

Please install the Ubuntu MythTV debug package (rather than recompiling) and get a useful backtrace as described at http://www.mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2 .

Sorry for being a noob, but,

apt-get install mythtv-debug couldn't find the package.

Searching google didn't seem to help. Is the package available in another repository somewhere ?

comment:3 Changed 11 years ago by robert.mcnamara@…

Ubuntu debug packages are accessed through their own repository. Check out this article:

https://wiki.ubuntu.com/DebuggingProgramCrash

comment:4 Changed 11 years ago by danielk

Resolution: wontfix
Status: newclosed

This looks like a QString issue, we're using Qt4 in trunk which is less prone to these segfaults than Qt3.

Note: See TracTickets for help on using tickets.