Opened 12 years ago

Closed 12 years ago

#6195 closed defect (fixed)

MythNews fails to fetch feeds with URLs containing URL parameters

Reported by: otto at kolsi dot fi Owned by: paulh
Priority: minor Milestone: 0.22
Component: Plugin - MythNews Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

MythNews? fails to load feeds with URLs that have URL-parameters. Examples are the Google News <http://news.google.com/?output=atom> and New York Times Country news feeds (contain ?rss=1 parameter).

Problem seems to be with QUrl.path() which now with qt4 does not seem to return the URL-parameter part of the URL. This probably was different with qt3.

I've attached quick and dirty patch that seems to work with feeds mentioned earlier. Myth's Trac feeds however still do not work with this patch. Either it is something else or the really simple fix in the patch does not work correctly in all cases.

The problem is in mythhttphandler.cpp so if that is used somewhere else, similar problems might be present there.

Attachments (1)

myth-httphandler.patch (539 bytes) - added by otto at kolsi dot fi 12 years ago.

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by otto at kolsi dot fi

Attachment: myth-httphandler.patch added

comment:1 Changed 12 years ago by Nigel

Not sure, but this might also be related to [17896], [18193] & [18194]

comment:2 Changed 12 years ago by paulh

Milestone: unknown0.22
Owner: changed from Isaac Richards to paulh
Status: newassigned

comment:3 Changed 12 years ago by paulh

Resolution: fixed
Status: assignedclosed

(In [19991]) Fix MythHttpHandler::Get() not working with many URLs.

In particular this fixes MythNews? not working with any feed where the URL contained a query. Fixes #6195.

Note: See TracTickets for help on using tickets.