Opened 11 years ago

Closed 10 years ago

#6216 closed defect (invalid)

Exported videos with pink squares

Reported by: vodicka.petr@… Owned by: xris
Priority: critical Milestone: unknown
Component: Apps - Nuvexport Version: 0.21
Severity: medium Keywords: nuvexport pink squares corrupted image
Cc: Ticket locked: no

Description

I have OpenSUSE 11.1 64bit, nuvexport 0.5.svn20081227-0.pm.3, transcode 1.1.0-0.pm.0 and MPlayer 1.0rc2_r27637-3.pm.3, mythtv 0.21 - svn19318.

If I try to export any recording with nuvexport, I get corrupted videos. I tried export with ffmpeg (i had to make changes - ticket #6214), transcode (#6215) and mencoder (no modification necessary) as well. Everytime same result - pink squares showing in moving picture. Key frames are ok.

I was using about half year old working version in OpenSUSE 11.0, but after upgrade this happened. I don't know where to search...

Attachments (1)

Corrupted.png (215.1 KB) - added by vodicka.petr@… 11 years ago.
Corrupted output video from nuvexport

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by vodicka.petr@…

Attachment: Corrupted.png added

Corrupted output video from nuvexport

comment:1 Changed 10 years ago by mytv.20.zdux0012@…

Getting same behavior on Fedora 10 actually mythdora. This is how it works out of the box. Tried with --mencoder and nuvexport-xvid and nuvexport-divx. It seems to me if the key frames were to over lay the pink squares (no change) then the picture would be perfect. I think this uses a multipass technique, so I would guess the error comes in the second pass. The first pass might suggest ignore this area, (use the key frame) the second pass mis-identifies the pink square as new information.

On an alightly-realted subject I would really like an editor that would allow me to manually encode a video. If anyone knows of such a program I would like to play with it.

comment:2 Changed 10 years ago by xris

Status: newinfoneeded_new

Unless someone can prove to me otherwise, I'm pretty sure this is a bug with libxvid, which is used by all of the apps you've mentioned.

I'll leave this as needinfo for awhile, in case you can come up with a cli option that fixes things.

comment:3 Changed 10 years ago by anonymous

The bug is still present in a single pass

comment:4 Changed 10 years ago by stuartm

Resolution: invalid
Status: infoneeded_newclosed

Bug in external library, closing as invalid.

Note: See TracTickets for help on using tickets.