Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#6221 closed defect (invalid)

Multytenne dish (DISEQC) not supported in mythtv-setup

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.21
Severity: medium Keywords: multytenne, diseqc, mythtv-setup
Cc: Ticket locked: no

Description

Multytenne is a satellite dish with built in DISEQC to be able to receive channels from 4 different satellites. In mythtv-setup, I setup this dish as diseqc with 4 ports. Then, when searching for channels on either port, it always searches on the first (astra 1) port. It is not possible to fe. search on the 10773 frequency of Astra2, instead it will come up with the Polish channels on Astra 1.

Attachments (1)

multytenne.log (90.3 KB) - added by cg@… 11 years ago.
mythtv-setup with multytenne and -v channel,record

Download all attachments as: .zip

Change History (7)

comment:1 Changed 11 years ago by Dibblah

Status: newinfoneeded_new

Duplicate of closed #5703

Please provide more details. Logs with:

mythbackend -v channel,record

may help.

Changed 11 years ago by cg@…

Attachment: multytenne.log added

mythtv-setup with multytenne and -v channel,record

comment:2 Changed 11 years ago by cg@…

I have the same problem (running trunk). MythTV always selects DiSEqC-Port 1 (which is Astra).

multytenne.log: mythtv-setup with -v channel,record.

comment:3 Changed 11 years ago by danielk

Resolution: invalid
Status: infoneeded_newclosed

new patch... we have little hope of writing one without having the hardware ourselves.

comment:4 Changed 11 years ago by anonymous

Did anyone find a solution/workaround?

I am experiencing this also with a Multytenne 45 twin and a Technotrend S-1500 + Technotrend S-3200. It doesn't work as it should for both tuner cards.

It seems sometimes is works, but most of the time the built-in DiSEqC switch doesn't switch. I could scan position 4 (28.2) once, and watch the channels. (BBC) I could switch without any problems from position 1 to 4 and back, several times. But, ater restarting mythtv this was no longer possible. :-(

However, I don't think this is a bug in MythTV, as I'm also unable to use DiSEqC commands with dvdtune.

dvdtune -D 1 and -D 3 both give Port 1, dvdtume -D 2 and -D 4 both give something else (not necesarily the same, but at least not port 1)

Maybe this antenna consumes too much power for the tuner card to supply? I don't realy know what the problem is...

comment:5 Changed 11 years ago by Jo Heremans <jo@…>

I had the same problem. I attached a patch for it in ticket 5703.

Daniel,

I saw you're response after 2 months, I know very late. Which commands are broken with the patch I attached ?

Greetz, Jo

comment:6 Changed 11 years ago by danielk

Jo, the patch just sent one less than the number of repeats requested by the API user so it was incorrect. The correct thing to do is lower the number of repeats requested, assuming the repeats are causing a problem.

Note: See TracTickets for help on using tickets.