Opened 11 years ago

Closed 10 years ago

#6240 closed defect (fixed)

.srt subtitles no longer working

Reported by: anonymous Owned by: danielk
Priority: minor Milestone: 0.22
Component: MythTV - Video Playback Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Problem: mythvideo internal player no longer loads .srt subtitles. Get 'No captions'on OSD when loading.

Version: svn trunk 19951

Logs: Nothing shows up in frontend log, not sure what '-v' to use (tried "osd,playback")

Attachments (5)

patch_external_subtitles.diff (3.2 KB) - added by jo@… 10 years ago.
patch external subtitles
subfix.diff (39.4 KB) - added by robert.mcnamara@… 10 years ago.
Fixes issue, also adds subtitle support for storage groups (and theoretically for recording storage groups too)
subfix.2.diff (39.5 KB) - added by robert.mcnamara@… 10 years ago.
Tiny update, just to apply properly to current revision
subfix.3.diff (40.8 KB) - added by robert.mcnamara@… 10 years ago.
Missed a file's diff in the previous patch
6240-v1.patch (7.8 KB) - added by danielk 10 years ago.
work in progress..

Download all attachments as: .zip

Change History (14)

comment:1 Changed 10 years ago by Anduin Withers

Resolution: invalid
Status: newclosed

Changed 10 years ago by jo@…

patch external subtitles

comment:2 Changed 10 years ago by jo@…

with revision 19417 the function "LoadExternalSubtitles?" was deleted in tv_play.cpp

comment:3 Changed 10 years ago by danielk

Component: Plugin - MythVideoMythTV - Video Playback
Milestone: unknown0.22
Owner: changed from Anduin Withers to Isaac Richards
Resolution: invalid
Status: closednew

comment:4 Changed 10 years ago by elkin@…

Confirmed, patch works with current trunk.

Changed 10 years ago by robert.mcnamara@…

Attachment: subfix.diff added

Fixes issue, also adds subtitle support for storage groups (and theoretically for recording storage groups too)

comment:5 Changed 10 years ago by danielk

Owner: changed from Isaac Richards to danielk
Status: newaccepted

Changed 10 years ago by robert.mcnamara@…

Attachment: subfix.2.diff added

Tiny update, just to apply properly to current revision

comment:6 Changed 10 years ago by skerit@…

I'm afraid I'm getting an error in your latest patch:

textsubtitleparser.cpp: In static member function ‘static bool TextSubtitleParser::LoadSubtitles(QString, TextSubtitles&)’:
textsubtitleparser.cpp:113: error: ‘struct demux_sputext_t’ has no member named ‘file_ptr’
textsubtitleparser.cpp:115: error: ‘struct demux_sputext_t’ has no member named ‘file_ptr’
textsubtitleparser.cpp:121: error: ‘struct demux_sputext_t’ has no member named ‘file_ptr’
textsubtitleparser.cpp:165: error: ‘struct demux_sputext_t’ has no member named ‘file_ptr’
make[2]: *** [textsubtitleparser.o] Fout 1
make[2]: Map '/usr/local/src/mythtv/mythtv/libs/libmythtv' wordt verlaten
make[1]: *** [sub-libmythtv-make_default] Fout 2
make[1]: Map '/usr/local/src/mythtv/mythtv/libs' wordt verlaten
make: *** [sub-libs-make_default-ordered] Fout 2

Changed 10 years ago by robert.mcnamara@…

Attachment: subfix.3.diff added

Missed a file's diff in the previous patch

comment:7 Changed 10 years ago by danielk

(In [20600]) Refs #6240. This just changes xine_demux_sputext.c to xine_demux_sputext.cpp, a future changeset will actually use this (see ticket for details).

Changed 10 years ago by danielk

Attachment: 6240-v1.patch added

work in progress..

comment:8 Changed 10 years ago by danielk

Note: The patch I just attached is completely untested, it's just Robert McNamara??'s code massaged to apply to the latest sources.

Before applying I will probably move the subtitle filename detection to a lower level so that it does not need to inefficiently search for subtitle files in using remote storage groups code. The subtitle file should always be stored in the same directory as the video file, so if we move the filename detection code deeper down, perhaps into the RingBuffer?? class then we can determine the any external subtitle filenames much more efficiently...

comment:9 Changed 10 years ago by danielk

Resolution: fixed
Status: acceptedclosed

(In [20879]) Fixes #6240. Look up subtitle files efficiently and allow them to be streamed.

This re-enables external subtitles. Both the frontends and backends need to be upgraded for full functionality, but the protocol is no incremented since it is backward compatible. The subtitle file must be in the same directory as the video file. That directory is checked for subtitle files either by RingBuffer? for local files or the backend containing the video file for remotely streamed files.

Note: See TracTickets for help on using tickets.