Opened 11 years ago

Closed 10 years ago

#6253 closed defect (invalid)

Problems on live channel change using VDPAU

Reported by: dado483 Owned by: Isaac Richards
Priority: major Milestone: unknown
Component: MythTV - General Version: unknown
Severity: high Keywords: vdpau
Cc: Ticket locked: no

Description

Dear all, i'm using svn r19970, ubuntu 8,04 and Nvidia Drivers 180.29. I have an Nvidia 9400GT Silent (Club3d). When i start live tv watching an hd channel all is ok and both audio and video works fine (CPU take only 3% of work). The problem is when i change channel for watch another hd channel: audio takes about 10 second for work correctly (initially hags a lot of times) and when it seem to be started ok, after about 5 second video start hags a lot of time with micro steps that cause a very unpleasant effect. Closing live tv (so i return to the mythfrontend main menu) and then restarting it all is ok up to a new channel change. Using VDPAU on SD channels all works fine. Thanks a lot for your help.

Davide

P.S.: now i'm using Temporal 2x deinterlacing, but the problem is the same also without deinterlacer

Attachments (1)

mythfrontend.log (56.7 KB) - added by dado483 11 years ago.
mythfrontend -v playback log

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by markk

Status: newinfoneeded_new

Can you please attach logs produced by:-

mythfrontend -v playback

for a full sequence of channel changes.

comment:2 Changed 11 years ago by dado483

I've attached my log file. Channel change is at time 12:24:29:855 in the log. Before the channel change, the video stream was perferct, no hags and no micro steps. After the channel change, initially the audio is played with a lot of hangs, but after 10 second is ok; instead video hags continuously with a lot of micro steps during all the playback of the new channel.

Thanks for your help! Davide

Changed 11 years ago by dado483

Attachment: mythfrontend.log added

mythfrontend -v playback log

comment:3 Changed 11 years ago by markk

Can you check/confirm a couple of things:-

  • does everything work as expected if you don't use VDPAU at all? (e.g. just use ffmpeg + xv_blit)
  • does this work if you just use VDPAU for rendering? (i.e. use standard/ffmpeg for decoding)
  • what happens if you don't use digital audio output? (i.e. disable passthrough)
  • what happens if you disable audio entirely? (i.e. disable passthrough and set audio device to NULL)

comment:4 Changed 11 years ago by dado483

Ok, test i did the test you requested.

1) If i do not use VDPAU (ffmpeg+xv_blit) all work fine, cpu obviously is 50% loaded.

2) I dont'know if i understood correctly, but i've tested using standard/ffmpeg+opengl and all work fine (CPU 50% loaded)

3) Using VDPAU and disabling flags (AC3 passthrough and DTS passthrough), audio is in PCM stereo (correctly) but video has the same problems i described after a channel change

4) Using VDPAU and disabling audio (NULL device setted), video has the same problems i described after a channel change.

For point 3 and 4, the first channel after livetv start, work fine, the problem is after a channel change.

Thanks!

comment:5 Changed 11 years ago by dado483

I've upgraded nvidia drivers and mythtv to rev. 20020. I've turned off "Aggressive audio buffering" and now the situation is much improved.

Only sometimes audio stuck for milliseconds, video seems to be ok.

comment:6 Changed 11 years ago by anonymous

Sorry, Nvidia drivers are 180.37

comment:7 Changed 10 years ago by paulh

Resolution: invalid
Status: infoneeded_newclosed

Seems this was fixed by using newer Nvidia drivers so not a Myth bug.

Note: See TracTickets for help on using tickets.