Opened 13 years ago

Closed 13 years ago

#626 closed defect (duplicate)

Segfault when recording MPEG4 video after revert in mpegvideo_mmx_template.c

Reported by: goraczkm Owned by: Isaac Richards
Priority: blocker Milestone: unknown
Component: mythtv Version:
Severity: high Keywords:
Cc: Ticket locked: no

Description

Any recording started from on my V4L card segfault in the dct_quantize_SSE2. The problem seem to be cause by a line that wasn't removed after a revert. The line is showed in the following diff between the revision 7766 (revert to before 7721) and the previous working revision 7412:

http://cvs.mythtv.org/cgi-bin/viewcvs.cgi/trunk/mythtv/libs/libavcodec/i386/mpegvideo_mmx_template.c?root=svn&rev=7766&r1=7412&r2=7766

Removing the "push %%"REG_c" \n\t" fix the problem for me and really revert the files to version before 7221 as intended by revision 7766.

Change History (1)

comment:1 Changed 13 years ago by Isaac Richards

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.