Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#6265 closed defect (worksforme)

Mythvideo removed all (remote)files with umlauts in filename and don't readd them

Reported by: Markus Schulz <msc@…> Owned by: Anduin Withers
Priority: minor Milestone: unknown
Component: Plugin - MythVideo Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

i've switched from local files to remote available files (new mythvideo feature) via db-update (update query which removed the basepath portion and set the hostname). After first "scan for change" mythvideo removes all files with umlauts:

2009-02-14 11:09:30.182 Removing file SG(mythtv) :serien/Boston Legal/Staffel? 1/Boston Legal S01E01 - Revierkämpfe.avi: ...

And don't readd them back, therefore no files with umlauts could be viewed no.

Change History (7)

comment:1 Changed 11 years ago by Rob Smith

Status: newinfoneeded_new

Seems to work for me, can you try on a current version of -trunk and see if it's still an issue?

comment:2 Changed 11 years ago by Damian O'Sullivan <damian@…>

Kormoc,

Were you trying with streaming? This does not work for me either. I was talking to gbee about it in IRC.

Damian.

comment:3 Changed 11 years ago by jochen

Still not working with current trunk on m< s<stem. Videos with ä,ö and ü are not aaded to the videometadata table

comment:4 Changed 11 years ago by greg

Status: infoneeded_newnew

This works fine for me. Both scanning and playback via both NFS mounted fs and SG streaming.

I think this might be something locale or MySQL related.

root@bork:/data/video2/z-m# ls -lb testingäöümoo.avi -rw-r--r-- 1 root root 244908650 2009-08-10 11:22 testingäöümoo.avi

2009-08-10 11:22:52.095 Adding : : z-m/testingäöümoo.avi

2009-08-10 11:23:32.683 RingBuf?(myth://Videos@192.168.0.15:6543/z-m/testingäöümo o.avi): CalcReadAheadThresh?(0 KB)

2009-08-10 11:27:56.599 RingBuf?(/data/video2/z-m/testingäöümoo.avi): OpenFile?(/d ata/video2/z-m/testingäöümoo.avi, 12) 2009-08-10 11:27:56.601 RingBuf?(/data/video2/z-m/testingäöümoo.avi): CalcReadAhe? adThresh(0 KB)

-> threshhold(64 KB) min read(0 KB) blk size(32 KB)

comment:5 Changed 11 years ago by robertm

Resolution: worksforme
Status: newclosed

This appears to be a non-bug setup (locale or mySQL) issue. Closing this for now, but I encourage discussion on the dev list so that we can determine what the cause is so that we can troubleshoot it for people. For reference, this (including all above examples) works properly here.

comment:6 Changed 11 years ago by damian@…

I meant to update this earlier. Markus,

Try deleting all entries for these filenames from videometadata and rescanning. I found that it worked for me this way.

D.

comment:7 Changed 11 years ago by jochen

it now also works on my system.

i've had wronk characters in filename because only in samba ü,ä and ö were right, but not the linux filename!

but i don't know why the wrong ones were not added??

now it works, had to put following in my samba conf:

unix charset = iso8859-15 display charset = iso8859-15 dos charset = cp850

Note: See TracTickets for help on using tickets.