Opened 11 years ago

Closed 11 years ago

#6281 closed defect (fixed)

Missing option value for argument in transcode

Reported by: rnestor@… Owned by: Isaac Richards
Priority: major Milestone: unknown
Component: MythTV - Mythtranscode Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The 0.21-20 version of mythtv for OpenSUSE 11.1 downloaded from packman can't rip DVDs in most modes. The command passed to transcode doesn't provide an option value for the "-V" argument. Previous versions of transcode didn't require an option value but the latest version 1.1.0 does. The result is that any DVD rip that requires post-processing via transcode fails.

Attachments (1)

x (487 bytes) - added by anonymous 11 years ago.

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by anonymous

Attachment: x added

comment:1 Changed 11 years ago by otto at kolsi dot fi

In addition to mtd, this same problem is present in nuvexport when using transcode.

$ transcode --version
transcode v1.1.2 (C) 2001-2003 Thomas Oestreich, 2003-2009 Transcode Team

$ /bin/nice -n19 transcode -V --print_status 16 --import_asr 3 --export_asr 3 --export_fps 25.000,3 -Z 624x352 -k -i /tmp/fifodir_21733/vidout -p /tmp/fifodir_21733/audout -H 0 -x raw -g 720x576 -f 25.000,3 -n 0x1 -e 48000,16,2 -J smartyuv  -y xvid4  -N 0x55 -b 128,0,2,0 -R 3 -w 6 -o './TempFile.45.avi' 2>&1
[transcode] critical: bad argument for -V/--video_format, should be one of: yuv420p (default), yuv422p, rgb24

comment:2 in reply to:  1 Changed 11 years ago by otto at kolsi dot fi

Replying to otto at kolsi dot fi:

In addition to mtd, this same problem is present in nuvexport when using transcode.

$ transcode --version
transcode v1.1.2 (C) 2001-2003 Thomas Oestreich, 2003-2009 Transcode Team

$ /bin/nice -n19 transcode -V --print_status 16 --import_asr 3 --export_asr 3 --export_fps 25.000,3 -Z 624x352 -k -i /tmp/fifodir_21733/vidout -p /tmp/fifodir_21733/audout -H 0 -x raw -g 720x576 -f 25.000,3 -n 0x1 -e 48000,16,2 -J smartyuv  -y xvid4  -N 0x55 -b 128,0,2,0 -R 3 -w 6 -o './TempFile.45.avi' 2>&1
[transcode] critical: bad argument for -V/--video_format, should be one of: yuv420p (default), yuv422p, rgb24

Doh.. this issue was just fixed in [20332].

comment:3 Changed 11 years ago by Dibblah

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.