Opened 11 years ago

Closed 11 years ago

#6290 closed patch (fixed)

mythtv-setup mythui conversion and backend auto-stop/start

Reported by: Matthew Wire <devel@…> Owned by: Nigel
Priority: minor Milestone: unknown
Component: MythTV - General Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

  • Converts dialogs to mythui.
  • Warns user if backend is currently recording/running.
  • Offers to stop/start backend if commands are defined (See Note(1)).
  • Creates a new class in setupdialog.h/cpp which handles the dialogs and menu instead of all being handled in main - this makes it easier to handle dialog events since the whole thing is wrapped up within a class.

Note(1): auto stop/start backend functionality will only be available if MythbackendStartCommand?? and MythbackendStopCommand?? are defined in the database settings table.

Note(2): mythtv-setup-backendsettings adds two text settings to configuration for MythbackendStartCommand? and MythbackendStopCommand?. Default to null so option to stop/start backend will not be available unless these are specified.

Note: See #4184 for a previous version of the backend start/stop stuff

Attachments (5)

00-mythtv-setup.patch (16.8 KB) - added by Matthew Wire <devel@…> 11 years ago.
Main patch
01-mythtv-setup-backendsettings.patch (1.8 KB) - added by Matthew Wire <devel@…> 11 years ago.
Settings gui
01-6290-mythtv-setup-backendsettings.patch (1.8 KB) - added by Matthew Wire <devel@…> 11 years ago.
Refresh against 20301
90-6290-mythtv-setup.patch (7.5 KB) - added by Matthew Wire <devel@…> 11 years ago.
Updated patch for 20683
01-6290-mythtv-setup-backendsettings.2.patch (1.8 KB) - added by Matthew Wire <devel@…> 11 years ago.
Updated patch for 20683

Download all attachments as: .zip

Change History (10)

Changed 11 years ago by Matthew Wire <devel@…>

Attachment: 00-mythtv-setup.patch added

Main patch

Changed 11 years ago by Matthew Wire <devel@…>

Settings gui

Changed 11 years ago by Matthew Wire <devel@…>

Refresh against 20301

Changed 11 years ago by Matthew Wire <devel@…>

Attachment: 90-6290-mythtv-setup.patch added

Updated patch for 20683

Changed 11 years ago by Matthew Wire <devel@…>

Updated patch for 20683

comment:1 Changed 11 years ago by Matthew Wire <devel@…>

Updated patch. This version doesn't modify main.c so much and adds startprompt.cpp/h instead as requested by Nigel.

comment:2 Changed 11 years ago by Nigel

(In [20966]) Offer to automatically shutdown backend at start, shows recording status, starts up again on exit. Just a few minor whitespace changes from Matt's patch. Refs #6290.

comment:3 Changed 11 years ago by Nigel

Owner: changed from Isaac Richards to Nigel
Status: newassigned

Can't believe the original patch, #4184, was submitted 20 months ago!
I suspect that ExitPrompt? should be prompting to start the backend (instead of always doing it), and I think this currently needlessly runs BackendStartCommand? even if the backend is already running, but that can be refined later on?

comment:4 Changed 11 years ago by anonymous

Wow, many thanks for committing this Nigel[[BR]]
The logic is:

If mythtv-setup was asked to stop the backend it will automatically restart it. If mythtv-setup was asked to leave the backend running it will not restart it. If mythbackend was not running it will not restart it.

It uses the setting AutoRestartBackend? to decide whether or not to restart the backend on exit.

comment:5 Changed 11 years ago by Nigel

Resolution: fixed
Status: assignedclosed

I thought there was a situation where it tried to needlessly restart, but I can't reproduce. Prompting the user about the restart is still probably a good idea, but time to close this

Note: See TracTickets for help on using tickets.