Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#6315 closed defect (invalid)

LIRC Keypresses sent to both mythwelcome and mythfrontend

Reported by: Matthew Wire <devel@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When pressing "Menu" in mythfrontend the menu in mythwelcome is also activated. Subsequent keypresses activate menu items in both mythfrontend and mythwelcome.

Expected behaviour: Keypresses are not sent to mythwelcome when mythfrontend is running.

I am using blackbox window manager with LIRC and mythfrontend is launched from mythwelcome.

Attachments (1)

00-6315-mythwelcome-lircmenuhack.patch (881 bytes) - added by Matthew Wire <devel@…> 11 years ago.
Hack to disable menu if mythfrontend is running

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by Matthew Wire <devel@…>

Hack to disable menu if mythfrontend is running

comment:1 Changed 11 years ago by Matthew Wire <devel@…>

This is an ugly hack which checks if mythfrontend is running and does not run the menu code in mythwelcome if it is. Obviously this doesn't take into account any other keybindings for mythwelcome but does fix my immediate problem (I modify the menu locally so everything is accessible from the menu and extra keybindings are not required).

A proper fix could be a lot more difficult since the lirc code is within mythcontext and doesn't differentiate between mythwelcome and mythfrontend.

comment:2 Changed 11 years ago by Matthew Wire <devel@…>

Note that this bug doesn't seem to affect keybindings that launch pre-mythui screens (eg. info key launches welcome settings only when mythfrontend is not running).

comment:3 Changed 11 years ago by paulh

Matthew I run MythWelcome? on my production system and haven't noticed any problems like this but then again I haven't really tried to reproduce this bug.

What should happen is the myth_system() call used to start the FE will block MythWelcome? from seeing any lirc key presses until the FE is stopped only then will myth_system() re-enable them again. What does your command to start the FE look like in MythWelcome?'s settings? Just wondering if you have added a & to the end of it causing it to return immediately which would allow MythWelcome? to see those key presses even when the FE is running?

comment:4 Changed 11 years ago by Matthew Wire <devel@…>

Thanks for the explanation Paul. You were exactly right, I have a script which was running mythfrontend with &. Taken that away and it's fine!

comment:5 Changed 11 years ago by paulh

Resolution: invalid
Status: newclosed

comment:6 Changed 11 years ago by Matthew Wire <devel@…>

Seems it's not quite fine... I've just found out why I originally put the "&" in there. If mythfrontend is allowed to block it also blocks irexec from working (I have a number of external scripts for power on/off and volume control of my amp). irexec command line is irexec -d /home/mythtv/.lircrc.

Note: See TracTickets for help on using tickets.