Opened 11 years ago

Closed 10 years ago

#6339 closed defect (fixed)

Channel scanner doesn't storage bandwidth value for DVB-T transports

Reported by: cg@… Owned by: danielk
Priority: minor Milestone: 0.22
Component: MythTV - Channel Scanner Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When scanning for channels, the channel scanner fills an empty value for the bandwidth of a DVB-T transport.

Tuning to the transport fails in DTVMultiplex::ParseDVB_T at line 137. The log shows something like "Failed to initialize multiplex options".

Manually setting dtv_multiplex.bandwidth to 8 (8 MHz) fixes this.

Change History (2)

comment:1 Changed 10 years ago by Nick Morrott <knowledgejunkie (at) gmail (dot) com>

During some testing of the current channel scanner in trunk for UK DVB-T, I could not reproduce this issue.

The bandwidth entries for multiplexes found via individual tuned scans were set to 'a', rather than '8' (although note the 'Unsupported bandwidth parameter' message during tuning. The one multiplex found during a Full Scan for the UK had its bandwidth value set to 8.

A subsequent tuned scan on anexisting multiplex entry having bandwidth set to 'a' did not have any issues detecting the mutliplex and programs carried on it (see log below). Tuning to a channel on the multiplex within LiveTV was also successful.

MythTV config:

# /usr/local/mythtv-trunk/bin/mythbackend --version
Please include all output in bug reports.
MythTV Version   : 20770
MythTV Branch    : trunk
Library API      : 0.22.20090424-2
Network Protocol : 45
QT Version       : 4.5.2
Options compiled in:
 linux release using_oss using_alsa using_backend using_dvb using_frontend [[BR]]
using_hdpvr using_iptv using_ivtv using_lirc using_mheg using_opengl_video [[BR]]
using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv [[BR]]
using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python [[BR]]
using_opengl using_ffmpeg_threads using_live using_mheg

Verbose logging:

2009-07-06 07:11:04.073 ChannelScanSM(/dev/dvb/adapter102/frontend0): Tuning to Transport ID 20480 mplexid(7)
2009-07-06 07:11:04.073 SM(/dev/dvb/adapter102/frontend0)::AddFlags: Seen() Match() Wait(Pos,)
2009-07-06 07:11:04.079 DVBChan(1:/dev/dvb/adapter102/frontend0) Warning: Unsupported bandwidth parameter.
2009-07-06 07:11:04.079 DVBChan(1:/dev/dvb/adapter102/frontend0) Warning: Unsupported hierarchy parameter.
2009-07-06 07:11:04.079 DVBChan(1:/dev/dvb/adapter102/frontend0): 722166670 auto a auto auto a a auto a v
2009-07-06 07:11:04.080 DVBChan(1:/dev/dvb/adapter102/frontend0): Old Params: 0 auto a auto auto a a auto a v
                        DVBChan(1:/dev/dvb/adapter102/frontend0): New Params: 722166670 auto a auto auto a a auto a v
2009-07-06 07:11:04.080 DVBChan(1:/dev/dvb/adapter102/frontend0): Tune(): Tuning to 722166670Hz
2009-07-06 07:11:04.646 dvbchannel.cpp:wait_for_backend: Status: Signal,
2009-07-06 07:11:04.647 DVBChan(1:/dev/dvb/adapter102/frontend0): Tune(): Frequency tuning successful.
2009-07-06 07:11:04.647 DTVSM(/dev/dvb/adapter102/frontend0)::SetChannel(-1, -1):
2009-07-06 07:11:04.647 SM(/dev/dvb/adapter102/frontend0)::Start: begin
2009-07-06 07:11:04.647 SM(/dev/dvb/adapter102/frontend0)::AddFlags: Seen() Match() Wait(Sig,)
2009-07-06 07:11:04.647 SM(/dev/dvb/adapter102/frontend0)::Start: end
2009-07-06 07:11:04.647 SM(/dev/dvb/adapter102/frontend0)::RemoveFlags: Seen() Match() Wait(Pos,)
2009-07-06 07:11:04.707 SM(/dev/dvb/adapter102/frontend0)::AddFlags: Seen() Match() Wait(Sig,)
2009-07-06 07:11:04.766 SM(/dev/dvb/adapter102/frontend0)::AddFlags: Seen() Match() Wait(Sig,)
2009-07-06 07:11:04.795 DVBSM(/dev/dvb/adapter102/frontend0): UpdateValues -- Signal Locked
2009-07-06 07:11:04.902 SM(/dev/dvb/adapter102/frontend0)::AddFlags: Seen(PAT,) Match() Wait()
2009-07-06 07:11:04.902 ChannelScanSM(/dev/dvb/adapter102/frontend0): Got a Program Association Table for Transport ID 20480

comment:2 Changed 10 years ago by Janne Grunau

Milestone: unknown0.22
Resolution: fixed
Status: newclosed

can't reproduce with current, probably fixed by one of the many channelscanner commits

Note: See TracTickets for help on using tickets.