Opened 12 years ago

Closed 11 years ago

#6341 closed defect (duplicate)

MythTV-Setup crashes when submitting icon-information to mythtv.org

Reported by: cg@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

After scanning for channels on a DVB-T source, I wanted to download icons using the integrated icon-downloader. This all works (though a progressbar for the download process would be nice, as the setup seems unresponsive then).

After exiting the icon downloader, mythtv-setup asks to submit icon information to mythtv.org. When choosing OK, the setup program quits with a segmentation fault.

Here's the backtrace from gdb:

2009-03-10 22:49:54.893 Menu Selection: 7276 TSI 1 http://lyngsat-logo.com/logo/tv/tt/tsi1.jpg

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fe3a437c700 (LWP 4600)]
QCoreApplication::postEvent (receiver=0x7fe394017330, event=0x5bdeb40, priority=0) at kernel/qcoreapplication.cpp:969
969	kernel/qcoreapplication.cpp: No such file or directory.
	in kernel/qcoreapplication.cpp
(gdb) bt
#0  QCoreApplication::postEvent (receiver=0x7fe394017330, event=0x5bdeb40, priority=0) at kernel/qcoreapplication.cpp:969
#1  0x00007fe3a1c1bbbb in MythConfirmationDialog::sendResult (this=0x545f2d0, ok=true) at mythdialogbox.cpp:283
#2  0x00007fe3a1c1bc22 in MythConfirmationDialog::Confirm (this=0x545f2d0) at mythdialogbox.cpp:263
#3  0x00007fe3a1c783fd in MythConfirmationDialog::qt_metacall (this=0x545f2d0, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x7fffac49ec40) at moc_mythdialogbox.cpp:141
#4  0x00007fe39d9c4036 in QMetaObject::activate (sender=0x5bcdf50, from_signal_index=<value optimized out>, to_signal_index=21, argv=0x7fffac49eb20) at kernel/qobject.cpp:3025
#5  0x00007fe3a1c779b0 in MythUIButton::Clicked (this=0x5bcdf50) at moc_mythuibutton.cpp:88
#6  0x00007fe3a1c0b75d in MythUIButton::Push (this=0x5bcdf50, lock=false) at mythuibutton.cpp:171
#7  0x00007fe3a1c0b8a9 in MythUIButton::keyPressEvent (this=0x5bcdf50, e=0x7fffac49f3f0) at mythuibutton.cpp:135
#8  0x00007fe3a1c1bc53 in MythConfirmationDialog::keyPressEvent (this=0x545f2d0, event=0x7fffac49f3f0) at mythdialogbox.cpp:229
#9  0x00007fe3a1bb673a in MythMainWindow::eventFilter (this=0x23b3150, e=0x7fffac49f3f0) at mythmainwindow.cpp:1375
#10 0x00007fe39d9b11cc in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x23b3150, event=0x7fffac49f3f0) at kernel/qcoreapplication.cpp:700
#11 0x00007fe39f4e7f6f in QApplicationPrivate::notify_helper () from /usr/lib/qt4/libQtGui.so.4
#12 0x00007fe39f4eef46 in QApplication::notify () from /usr/lib/qt4/libQtGui.so.4
#13 0x00007fe39d9b0ae4 in QCoreApplication::notifyInternal (this=0x7fffac4a05a0, receiver=0x23b3150, event=0x7fffac49f3f0) at kernel/qcoreapplication.cpp:589
#14 0x00007fe39f534dac in qt_sendSpontaneousEvent () from /usr/lib/qt4/libQtGui.so.4
#15 0x00007fe39f55d062 in QKeyMapper::sendKeyEvent () from /usr/lib/qt4/libQtGui.so.4
#16 0x00007fe39f55f29e in QKeyMapperPrivate::translateKeyEvent () from /usr/lib/qt4/libQtGui.so.4
#17 0x00007fe39f53e55b in QApplication::x11ProcessEvent () from /usr/lib/qt4/libQtGui.so.4
#18 0x00007fe39f55fff5 in QEventDispatcherX11::processEvents () from /usr/lib/qt4/libQtGui.so.4
#19 0x00007fe39d9afd75 in QEventLoop::processEvents (this=<value optimized out>, flags=@0x7fffac4a0080) at kernel/qeventloop.cpp:149
#20 0x00007fe39d9afee6 in QEventLoop::exec (this=0x7fffac4a00c0, flags=@0x7fffac4a00d0) at kernel/qeventloop.cpp:196
#21 0x00007fe39d9b20de in QCoreApplication::exec () at kernel/qcoreapplication.cpp:851
#22 0x000000000042346d in SetupMenu (win=0x23b3150) at main.cpp:99
#23 0x0000000000425b41 in main (argc=1, argv=0x7fffac4a0aa8) at main.cpp:349

Change History (2)

comment:1 Changed 11 years ago by laga

Possibly a duplicate of #6541.

comment:2 Changed 11 years ago by stuartm

Resolution: duplicate
Status: newclosed

Duplicate of #6541

Note: See TracTickets for help on using tickets.