Opened 11 years ago

Closed 11 years ago

#6343 closed defect (invalid)

Problem with VDPAU and Temporal 2X deinterlacing

Reported by: tralph11@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: head
Severity: medium Keywords: vdpau
Cc: Ticket locked: no

Description

I'm seeing a problem when using VDPAU and Temporal 2X deinterlacing to watch NBC primetime shows such as The Office, My Name is Earl, etc. When watching these shows flashes occur at scene changes that look like previous frames are getting inserted. According to the playback logs it appears that these broadcasts have frames marked interlaced and progressive. If I force the video scan to interlaced the video plays back perfectly. Also when using BOB 2X deinterlacing I don't see any visual problems.

You can download a sample below that visually shows the problem at a scene change and produces the mixed progressive/interlaced detection in the playback logs.

http://filebin.ca/qhduhd

Here is my relevant configuration details:

  • GeForce? 8400 GS PCI (memory clock @ 500 MHz)
  • Nvidia driver 180.37 (also tried several previous versions)
  • Compile information

MythTV Version : 20162M
MythTV Branch : trunk
Library API : 0.22.20090220-1
Network Protocol : 44
QT Version : 4.4.3
Options compiled in:
linux debug using_oss using_alsa using_backend using_directfb using_dvb using_firewire using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_libfftw3 using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_libavc_5_3 using_live using_mheg

Attachments (1)

playback.log (16.9 KB) - added by tralph11@… 11 years ago.
log showing interlaced and progressive frames detected

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by tralph11@…

Attachment: playback.log added

log showing interlaced and progressive frames detected

comment:1 Changed 11 years ago by markk

Resolution: invalid
Status: newclosed

This is working as intended.

More advanced deinterlacers (not just in vdpau) typically use 3 frames for processing - with the middle frame intended for display. This means there is a 1 frame discrepancy between the audio and video (which generally goes unnoticed). When the deinterlacer is then disabled there is a momentary re-adjustment of the video. Bob does not use the extra reference frames, hence no visual impact when switching.

Note: See TracTickets for help on using tickets.