Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#6356 closed defect (invalid)

In "Watch Recordings", unable to decode any MPEG videos if one in the list is unreadable

Reported by: jharris@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: 0.21
Severity: high Keywords:
Cc: Ticket locked: no

Description

I have had a functioning MythTV setup (Mythbuntu, mythtv-0.21) for several weeks now, but earlier today I suddenly lost the ability to watch recorded programs. Selecting any videos from the list of recordings resulted in either a blank screen, garbled noise, or (worst of all) a hung mythfrontend process that had to be killed from a vt.

It took me a while to understand what was happening. I had watched many of these recordings before, so I knew it was possible for MythTV to play them. Just to make sure the files were not corrupted somehow, I manually loaded a couple of them into mplayer, which played them without complaint.

I then launched mythfrontend from a konsole window, so I could get some feedback from the process. After trying to watch a recording, I exited from mythfrontend, and saw an error message like:

"NVP: Couldn't find a matching decoder for: <path to mpg file>"

So, it would seem my mythbox suddenly thinks it can't decode mpegs, which is ironic given that it's whole raison d'etre is to decode mpegs!

Anyway, to make a long story short, I eventually realized that my most recent recording was accidentally recorded from channel I don't actually receive. So the mpeg file was corrupted/garbage. And now we get to my bug report:

Somehow, the very presence of this invalid mpeg file in my list of recordings made it impossible to watch *any* of my recorded programs. Once I deleted the offending recording, I was then able to watch any of the others. It seems very strange to me that this problem was triggered even if I didn't attempt to watch the invalid recording. I am guessing that the explanation is that mythtv attempted to show the "thumbnail preview" of the recording (since it was the most recent recording, the preview would be triggered as soon as the list of recordings was shown).

Steps to reproduce: If you have a channel in your lineup that you don't actually receive a signal on (such as a premium channel, maybe), record a program on that channel. Then, try to watch any of your other recordings.

Workaround: I am going to remove all invalid channels from my lineup, which should avoid this issue. Still, I would think there may be other corner-cases where a invalid recording might cause similar problems.

Change History (4)

comment:1 Changed 11 years ago by Dibblah

Status: newinfoneeded_new

Given this level of detail, it's not possible to diagnose this issue. If you have a sample file that causes this issue, snip 10Mb or so from the beginning and try to see if you can replicate with that. If you can, then post it somewhere and put a URL to it in this ticket.

comment:2 Changed 11 years ago by danielk

Resolution: invalid
Status: infoneeded_newclosed

info not provided

comment:3 Changed 10 years ago by benklop@…

I also have this issue, and have posted the first 10 mb of the offending file to http://intellilinux.info/sites/default/files/test_corrupt.mpg For me, the effect is that if mythtv even tries to preview this file, mythtv is no longer able to play any video at all, until that section has been exited and returned to, or the FE has been restarted. This was recorded with an HD HomeRun?.

comment:4 Changed 10 years ago by benklop@…

I had this issue again last week with "so you think you can dance" - again mplayer could play back the file without a problem. If there is a need I will post a portion of that file as well.

Note: See TracTickets for help on using tickets.