Opened 11 years ago

Closed 10 years ago

#6367 closed defect (duplicate)

DVD viewing skips during DVD access

Reported by: bhuffman@… Owned by: skamithi
Priority: minor Milestone: 0.22
Component: MythTV - DVD Playback Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

As it says, I'm getting a very shot pause / skip that is noticable during high motion only during the access of the DVD drive. If I rip the DVD and then watch in mythvideo, I don't see this. Also, I don't see this in mplayer (hence my thought that it might be myth). I see this in both .21 fixes as well as .22 (after the latest dvdread/dvdnav patches).

Attachments (1)

dvd_stutter.diff (715 bytes) - added by skamithi 11 years ago.

Download all attachments as: .zip

Change History (28)

comment:1 Changed 11 years ago by stuartm

Status: newinfoneeded_new
Version: unknownhead

Increase the drive speed in the settings to max, iirc that's 12x. Does that fix it?

comment:2 Changed 11 years ago by stuartm

Component: Plugin - MythVideoMythTV - DVD Playback

comment:3 Changed 11 years ago by bhuffman@…

No - that does not fix it. In fact I don't think that the drive speed adjustment is working at all. When I watch the pattern of the drive light it doesn't change no matter whether the speed is set to 2 or 12. And there's an extremely obvious difference between mplayer (much faster light flickers) and mythtv.

comment:4 Changed 11 years ago by bhuffman@…

Any news on this?

comment:6 Changed 11 years ago by stuartm

Status: infoneeded_newnew
Ticket locked: set

comment:7 Changed 11 years ago by stuartm

Milestone: unknown0.22
Status: newinfoneeded_new
Ticket locked: unset

bhuffman, which version of trunk/fixes are you running? Skamithi committed a speed setting fix a while ago that seemed likely to fix this issue too.

comment:8 Changed 11 years ago by bhuffman@…

No -this did not fix the problem for me. I made sure to update beyond changeset 20272 (where skamithi made the change). I'm at .21-fixes 20276

comment:9 Changed 11 years ago by skamithi

Status: infoneeded_newnew

try the attached patch.

comment:10 Changed 11 years ago by skamithi

Owner: changed from Anduin Withers to skamithi
Status: newassigned

Changed 11 years ago by skamithi

Attachment: dvd_stutter.diff added

comment:11 Changed 10 years ago by stuartm

Status: assignedinfoneeded

As Skamithi asked 3 months ago, would someone affected by this issue please test the attached patch.

Possible duplicate of #6456

comment:12 Changed 10 years ago by bhuffman@…

I'll test this as soon as I am able. Right now, the DVD that I initially used to test won't play due to bug 6767 that I just posted. :-(

comment:13 Changed 10 years ago by alan@…

Hi,

Tested patch/change on top of 0.21+fixes-21006 (not trunk - downloaded from Mythbuntu, hand typed changes) noted additional code not shown in patch (see below) no idea if it is relevant

if (storedPackets.count() < 15 && !decodeStillFrame)

storevideoframes = true;

if (inDVDMenu && storedPackets.count() > 0)

ringBuffer->DVD()->SetRunSeekCellStart?(false);

else if (inDVDStill)

ringBuffer->DVD()->RunSeekCellStart?();

} if (GetNVP()->AtNormalSpeed?() &&

((cellChanged)
(lastdvdtitle != dvdtitle)))

{

if (dvdtitle != lastdvdtitle) {

VERBOSE(VB_PLAYBACK, LOC + "DVD Title Changed"); lastdvdtitle = dvdtitle;

).

Patch makes no difference to Animusic 2, Wall-E or Gladiator - all are as bad as ever with video stuttering. Now, after a period of stuttering the audio warps and speeds up and the stuttering seems better, then the audio settles back down and the stuttering is back. This may be a red-herring.

Wall-E's menus worked, but the FBI warning was skipped completely.

Thanks

Alan

comment:14 Changed 10 years ago by alan@…

Sorry, hadn't read the initial post properly for this bug report.

The symptoms may not be entirely the same as the issue I reported. High motion is not the only factor, I get consistent and repeated skips regardless of motion speed, camera pans etc. probably every 1-5 seconds on Animusic, and may be less often on other DVDs - but no DVD plays smoothly.

What is consistent is that I can rip the DVD and it plays perfectly. Also I can skip backwards, and the previously played sections play perfectly (I guess cached by the OS?), I can change the playback speed up or down and get completely smooth playback - which makes no sense to me - at 1.05x playback speed everything is smooth (just too fast) - but at 1.00x speed, it stutters.

comment:15 Changed 10 years ago by bhuffman@…

This patch did not fix the problem. I also tried increasing from 15 to 30. I'm wondering about the fact that the speed adjustment doesn't seem to work. Even when the speed is set to 12, it seems to flash fairly slowly (like once every .5 seconds) while mplayer accesses the drive very rapidly when playing the same DVD (w/o any noticeable skips / pauses).

This is more like an extremely brief pause than a skip. For example at the beginning of the movie Batman Begins, When the DC Comics is being panned across the screen and the individual circles (looks like pixels up close) are being lighted, there will be the most brief pause (like a hesitation while accessing more data) on the DVD. After watching once and rewinding, it appears to have the data cached and it won't happen again.

comment:16 Changed 10 years ago by skamithi

is this problem still present in the latest revision ?

comment:17 Changed 10 years ago by bhuffman@…

I'm afraid the problem is still present [21924]...this is such an illusive issue - it's hard to explain. It's really a small glitch - you don't hear anything in the audio and doing a "-v playback" doesn't show any problems. But during motion scenes where the video should be completely smooth, I'll see a very small pause in the video every so often when the drive is accessing the media. I use the opening credits for Batman Begins as a test b/c during the graphics of the DC Comics logo in the intro, I can catch it. I'm tempted to say it's something with my hardware, but I can't imagine what it'd be and since it doesn't happen in xine, I feel like at least something can be done in software to mask the effect (even if it is a hardware problem). Also, it still seems like the slider for DVD speed doesn't do anything - I have it turned up to "12" which should be basically unrestricted and I don't know that it's working correctly.

comment:18 Changed 10 years ago by stuartm

Status: infoneededassigned

I'm curious to know if disabling CPU frequency switching makes any difference? Especially if you have an AMD cpu. Choose the performance governor.

comment:19 Changed 10 years ago by bhuffman@…

It doesn't appear to be frequency scaling. I do not have any cpu frequency scaling software running and gnome says that it's not configured to do frequency scaling when I try to run the applet:

[root@xyz~]# chkconfig --list |grep -i cpu cpuspeed 0:off 1:off 2:off 3:off 4:off 5:off 6:off [root@xyz~]# ps -ef |grep -i cpu root 11315 10911 0 12:26 pts/0 00:00:00 grep -i cpu

My CPU is also not an AMD (from /proc/cpuinfo): model name : Intel(R) Core(TM)2 Duo CPU E7200 @ 2.53GHz

comment:20 Changed 10 years ago by alan@…

I am using an AMD CPU (3800+ Athlon64 X2 65W), and I do have frequency scaling enabled

sudo cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor ondemand

Disabling scaling makes no difference on 0.21 fixes 21768 - I still get pauses in video every second or so on Animusic2.

I haven't tested the latest version, as this is a real pain for me to do - so my results may be irrelevant - please confirm whether there are changes that could impact this, and I'll try and test this.

However, Xine and Totem do not suffer from these problems and changing playback speed to 1.1 or 0.9 in MythTV completely removes these pauses, so CPU scaling doesn't look like its the root cause of the problem.

comment:21 Changed 10 years ago by otto at kolsi dot fi

I've had exactly the same problems which have been described in this ticket. I also suspected that it is somehow related to the drive speed control, tried to look at the code and hack something with it, increase the speed above 12x etc. At the same time other players worked fine.

I was using ~5 years old bulk DVD-R drive but then tested bran new Samsung DVD-RW which was going to one other machine. And that fixed the problem for me! I'm not saying everyone should go and buy new drives.. just that for some reason it looked like Myth couldn't get data out fast enough from that drive.

comment:22 Changed 10 years ago by alan@…

I've tried both SATA and PATA DVD drives with exactly the same issues - it does appear to be drive related, but more in how the drive is accessed by MythTV than pure HW. Obviously I don't have an exhaustive selection of drives, the ones I've tested are LiteOn? - which work well in both of my frontend machines and every application, except MythTV on one machine.

comment:23 Changed 10 years ago by usg990a@…

I am experiencing the same problems on 2 different SATA ASUS drives and an IDE Samsung drive when using release-fixes-0.21 (any revision). As others have mentioned, it seems that the drive speed setting is not being acted upon (i.e. changes from 2x to 12x have no effect).

Could someone try writing a patch that disables the drive speed control (or advise where in the code I could find it)? Since this spans across multiple hardware setups, and the issues do not exist using the same hardware with mplayer or xine , it seems to be an issue with the mythtv code. I am just not sure where to look.

comment:24 Changed 10 years ago by Rob Smith

Are you running a tickless kernel? If so, try disabling that feature and see if the problem clears up (it did for me).

comment:25 Changed 10 years ago by alan@…

Thanks, for suggesting this. I tried this by adding nohz=off to my boot options and it made things worse. As well as the video stuttering, audio also started stuttered and crackled.

Like the OP, I believe the problem is related to how MythTV accesses the DVD drive. ISOs play perfectly across NFS, xine works great, just MythTV has problems with actual DVDs... The problem appears to be worse with higher quality DVDs, which I suspect use less compression, so more throughput would be needed. Like the OP, changing DVD access speed makes no difference on my machine - and that seems to be the problem.

Something was introduced between .20 and .21, because the problem really only reared its head on my system once I upgraded to .21.

comment:26 Changed 10 years ago by skamithi

pls check if the patch in #7605 resolves this problem.

comment:27 Changed 10 years ago by bhuffman@…

Yes!!!! #7605 fixes the problem for me! Woo hoo! Thanks!

comment:28 Changed 10 years ago by skamithi

Resolution: duplicate
Status: assignedclosed

dup of #7605.

Note: See TracTickets for help on using tickets.