Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6372 closed defect (invalid)

IR remote intermittently unresponsive on 'watch recordings' screen

Reported by: mythtv.org@… Owned by: Isaac Richards
Priority: major Milestone: unknown
Component: MythTV - General Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

On recent SVN builds (from last couple of months) the IR remote (Streamzap USB remote) becomes intermittently responsive on the 'watch recordings' screen. The keyboard works normally, and the remote works properly on all other screens. The same behavior is exhibited on three different machines; all machines are running Ubuntu (7.10, 8.04, and 8.10). Unfortunately, I did not catch the revision where the problems started.

Change History (9)

comment:1 Changed 10 years ago by paulh

Status: newinfoneeded_new

Paul, Is this still a problem with current trunk?

comment:2 Changed 10 years ago by mythtv.org@…

Yes. Built from latest (20472) this afternoon. Problem persists, but does seem somewhat better. The problem appears to be that when the next show's info is not ready to be displayed, instead of the system queueing the button press, it is dropped. This may not be showing up elsewhere simply because the data that needs to be displayed is already ready, whereas on the show recordings screen, there's data that needs to be fetched on each change (program description, preview). The problem shows up while going through a list, but going back through the same list (after the data has be fetched) seems to be OK.

comment:3 Changed 10 years ago by stuartm

You don't say which branch you are using?

comment:4 Changed 10 years ago by sphery <mtdean@…>

see, also, #5973

comment:5 Changed 10 years ago by mythtv.org@…

I am using the latest (ie trunk).

I mentioned earlier that I thought it had something to do with grabbing info for each show. Since then, I've noticed that even if I turn previews off, the frontend still grabs them, it just doesn't seem to display them.

comment:6 Changed 10 years ago by anonymous

I ran into this problem as well. I installed the latest trunk from MythBuntu? weekly builds and everything was working. I started watching LiveTV and then I hit record. I went to another channel on another tuner and I then decided I wanted to watch the one that was already recording. I went to the watch recordings screen and I experienced the same behavior as the remote wouldn't work and the keyboard would. I then stopped the recording with the keyboard after killing the frontend and the remote worked normally. I then went to the recording that I killed and it wouldn't play as it was corrupt. I then tried the process all over again and this time the recording wasn't corrupt so the remote worked as expected. I feel the corrupt recording is causing the issue. Unfortunately, I had to drop back to 0.21-fixes due to the WAF.

comment:7 Changed 10 years ago by danielk

Resolution: invalid
Status: infoneeded_newclosed

No useful information added to this ticket in 6 months since it was opened :(

comment:8 Changed 10 years ago by mythtv.org@…

I responded to the last request for information, but the ticket stayed at the 'info needed' status. Please reopen.

comment:9 in reply to:  7 Changed 10 years ago by mythtv.org@…

Replying to danielk:

No useful information added to this ticket in 6 months since it was opened :(

What information are you looking for, anyway? I'll be happy to add any logfiles or other pertinent data.

Note: See TracTickets for help on using tickets.