Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#638 closed defect (worksforme)

As of 7613 configure no longer sets processor optimization correctly.

Reported by: harley@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: low Keywords:
Cc: Ticket locked: no

Description

As the summary says configure no longer sets processor optimization. Sets march in my case to pentiumpro. Can be forced to pentium4 with --arch. There also seems to be a problem with libmpeg2 playback perfomance with this configure script. The cpu usage results are from the 7738 code using the configure script from before 7613 (in this case 7612) and the configure script that is part of the 7738 code.

SDTV cpu usage 7612 configure: 20%, SDTV cpu usage 7738 configure: 28%, HDTV cpu usage 7612 configure: 58%, HDTV cpu usage 7738 configure: 86%

This only seems to effect libmpeg2. ffmpeg seems unchanged. The latest configure script posted today (7841) doesn't fix either one of these problems.

Change History (8)

comment:1 Changed 14 years ago by danielk

Resolution: invalid
Status: newclosed

Invalid without params to and output of ./configure

Plus you might want to include the outputs of: "uname -m", "uname -p", and "cat /proc/cpuinfo"

comment:2 Changed 14 years ago by harley@…

Resolution: invalid
Status: closedreopened

./configure --enable-xvmc --enable-dvb --enable-opengl-vsync --disable-lirc --disable-joystick-menu --disable-dbox2

configure output

# Basic Settings Compile type release Compiler cache yes DistCC no Install prefix /usr/local CPU x86 (Intel(R) Pentium(R) 4 CPU 2.40GHz) Big Endian no MMX enabled yes Vector Builtins yes

# Input Support Joystick menu no lirc support no Video4Linux sup. yes ivtv support yes FireWire? support no DVB support yes usr/include DBox2 support no

# Sound Output Support OSS support yes ALSA support yes aRts support no JACK support no

# Video Output Support x11 support yes xrandr support yes xv support yes XvMC support yes XvMC VLD support no XvMC pro support no XvMC libs -lXvMCNVIDIA OpenGL vsync yes DirectFB no

# Misc Features DVD playback yes Frontend yes Backend yes

uname -m i686

uname -p Intel(R) Pentium(R) 4 CPU 2.40GHz

cat /proc/cpuinfo processor : 0 vendor_id : GenuineIntel? cpu family : 15 model : 2 model name : Intel(R) Pentium(R) 4 CPU 2.40GHz stepping : 4 cpu MHz : 2706.408 cache size : 512 KB fdiv_bug : no hlt_bug : no f00f_bug : no coma_bug : no fpu : yes fpu_exception : yes cpuid level : 2 wp : yes flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm bogomips : 5417.17

comment:3 Changed 14 years ago by harley@…

After looking into this a little more. The problem with libmpeg2 only happens when i compile with the option --arch=pentium4. Though this sets march to pentium4 it seems to be missing some setting that affects libmpeg2.

comment:4 Changed 14 years ago by danielk

Resolution: invalid
Status: reopenedclosed

You must add "--enable-proc-opt" to the params to get processor specific optimization.

comment:5 Changed 14 years ago by harley@…

Resolution: invalid
Status: closedreopened

--enable-proc-opt Does absolutely nothing and hasn't done anything for sometime and yes i have tried it many times. Even if it did work this doesn't address the first problem discussed in this ticket. Which is that the configure script doesn't detect the processor corretly to begin with. It sets it to pentium pro instead of pentium4 like it should and how it used to before 7613.

comment:6 Changed 14 years ago by danielk

Resolution: worksforme
Status: reopenedclosed

That option does work, and it works with that processor. It just happens I'm running that same processor. It is detected on line 1197 of the configure script. This is a bug tracking database and not a support forum.

Please post any questions you still have to the mythtv-users list.

comment:7 Changed 14 years ago by harley@…

Well i am glad it works for you. It does nothing here. This still doesn't address the first problem addressed in this ticket. And i never asked for help. Just reported a bug. Anyway pentium pro optimization works just as good as pentium4 so will consider this ticket closed.

comment:8 Changed 14 years ago by anonymous

if you'd like help, just give the needed information. Sure, you ran ./configure but you ran it without --enable-proc-opt. That's the ONLY way it will autodetect your processor. If it doesn't work for you, then fine... show us so it can be fixed.

Run: ./configure --enable-proc-opt --enable-xvmc --enable-dvb --enable-opengl-vsync --disable-lirc --disable-joystick-menu --disable-dbox2

...and post results so we can see that it isn't detecting your processor correctly.

Note: See TracTickets for help on using tickets.