Opened 11 years ago

Closed 11 years ago

#6388 closed defect (invalid)

mythbackend doesn't record scheduled schows

Reported by: Matthias "mortalmatt" Dahl <devel@…> Owned by: Isaac Richards
Priority: critical Milestone: 0.22
Component: MythTV - General Version: head
Severity: high Keywords:
Cc: Ticket locked: no

Description

Since I am currently working on an university project that's taking all my time, I am filing this bug instead of looking for the source of this problem myself:

Every now and then mythbackend doesn't record scheduled shows until it has been restarted. It already happened twice to me. Unfortunately there is nothing in the logs that could help except for the following line which showed up twice today:

QMutex::lock: Deadlock detected in thread

I only noticed the fault after a restart of my machine, so the possibility to attach gdb to the threads slipped again. Nevertheless I think it'd be a good idea to review all locking behaviour of MythTV before making a 0.22 release.

By the way, I am seeing this w/ mythtv trunk and qt 4.5.0. But I guess the problem is on mythtv's side.

Change History (1)

comment:1 Changed 11 years ago by danielk

Resolution: invalid
Status: newclosed

a backtrace at least to diagnose.

Note: See TracTickets for help on using tickets.