Opened 11 years ago

Closed 11 years ago

#6389 closed defect (invalid)

aspect ratio 16:9 shows black bars left and right

Reported by: sascha.zielinski@… Owned by: markk
Priority: minor Milestone: 0.22
Component: MythTV - Video Playback Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Since svn 20227 something has changed with aspect ratio. while watching a movie in 16:9 I have black Bars left and right. On my 16:10 display 16:9 video is displayed in fullscreen. I use "-O XineramaMonitorAspectRatio?=1.7777" for my 16:9 display and "-O XineramaMonitorAspectRatio?=1.6" for my 16:10 Display. Both logfiles are created with "-v all".

mythfrontend --version Please include all output in bug reports. MythTV Version : 20260 MythTV Branch : trunk Library API : 0.22.20090312-1 Network Protocol : 44 QT Version : 4.5.0 Options compiled in:

linux release using_oss using_alsa using_backend using_dvb using_frontend using_hdpvr using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_mheg

Attachments (2)

mythfrontend-vall.16.9.log (244.5 KB) - added by sascha.zielinski@… 11 years ago.
mythfrontend-vall.16.10.log (89.3 KB) - added by sascha.zielinski@… 11 years ago.

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by sascha.zielinski@…

Attachment: mythfrontend-vall.16.9.log added

Changed 11 years ago by sascha.zielinski@…

Attachment: mythfrontend-vall.16.10.log added

comment:1 Changed 11 years ago by markk

Owner: changed from Isaac Richards to markk
Status: newaccepted

comment:2 Changed 11 years ago by anonymous

Firstly, can you roll back your working copy to see if the cause is r20247 or r20252? That would be extremely helpful.

Secondly, can you generate (or not trim) those logs from when mythfrontend is started - I'm looking for the Xinerama/screen info that the frontend reports at startup. Additionally can you be more specific about your screen setup for each of those displays i.e. the number and size of screens, which of those screens the frontend is using, the override setting etc.

And finally (!), can you try each display without the XineramaMonitorAspectRatio? override. I'm wondering whether r20252 fixed an issue you were working around.

Mark

comment:3 Changed 11 years ago by sascha.zielinski@…

I set up two screens with twinview (0: 1920x1200 / 1: 1920x1080). After I played around with the settings, I found out, that I have to use XineramaScreen?. I used "-geometry .." before. Ticket can be closed. Thx for your reply.

comment:4 Changed 11 years ago by markk

Resolution: invalid
Status: acceptedclosed

Closed by request.

Note: See TracTickets for help on using tickets.