Opened 12 years ago

Closed 12 years ago

#6396 closed defect (fixed)

Shows with "An" in title crash MythTV when using the program finder

Reported by: frail.knight@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.21
Severity: medium Keywords: program finder sort alphabetical an crash
Cc: Ticket locked: no

Description

The program finder will crash MythTV and send the user to the desktop if they try to view the times and info for a show that includes "An" in its title such as "Unnatural Death, An". No errors are displayed.

Version output:

[mythtv@localhost ~]$ mythfrontend --version Please include all output in bug reports. MythTV Version : 0.21-16.1.md10 MythTV Branch : tags/release-0-21 Library API : 0.21.20080304-1 Network Protocol : 40 Options compiled in:

linux release using_oss using_alsa using_arts using_jack using_backend using_dbox2 using_dvb using_firewire using_frontend using_hdhomerun using_iptv using_ivtv using_joystick_menu using_lirc using_opengl_vsync using_opengl_video using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmcw using_xvmc_vld using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_libavc_5_3 using_live

[mythtv@localhost ~]$ mythbackend --version Please include all output in bug reports. MythTV Version : 0.21-16.1.md10 MythTV Branch : tags/release-0-21 Library API : 0.21.20080304-1 Network Protocol : 40 Options compiled in:

linux release using_oss using_alsa using_arts using_jack using_backend using_dbox2 using_dvb using_firewire using_frontend using_hdhomerun using_iptv using_ivtv using_joystick_menu using_lirc using_opengl_vsync using_opengl_video using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmcw using_xvmc_vld using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_libavc_5_3 using_live

Attachments (3)

pfind.diff (778 bytes) - added by robert.mcnamara@… 12 years ago.
fix.
patch-6396.cpp (477 bytes) - added by ylee@… 12 years ago.
Fix for 0.21-fixes
pfind.2.diff (511 bytes) - added by robert.mcnamara@… 12 years ago.
Yep, Yeechang's fix is better.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 12 years ago by robert.mcnamara@…

The crash isn't present in trunk, but it doesn't bring up the upcoming showings, either, so there's still a bug there. It looks like the "nice" version of the title with the ", An" is being passed into the SQL query so there are no results.

Changed 12 years ago by robert.mcnamara@…

Attachment: pfind.diff added

fix.

comment:2 Changed 12 years ago by robert.mcnamara@…

Here's a fix patch. Just reverses the logic to pretty up the title, seems to work here. Same logic can probably be applied to -fixes.

comment:3 Changed 12 years ago by robert.mcnamara@…

Sorry, just to be clear, the "nice" versions of the titles will still show in the program finder, this just straightens the titles out for the DB query only.

comment:4 Changed 12 years ago by ylee@…

I've reproduced the bug in 0.21-fixes as frail.knight described. Patch attached. It differs from Robert's fix for trunk in that in -fixes existing logic only needs to be extended to cover the "An" case, which was somehow left out.

Changed 12 years ago by ylee@…

Attachment: patch-6396.cpp added

Fix for 0.21-fixes

Changed 12 years ago by robert.mcnamara@…

Attachment: pfind.2.diff added

Yep, Yeechang's fix is better.

comment:5 Changed 12 years ago by anonymous

updated patch for trunk, Yeechang is right, I reinvented the wheel here.

comment:6 Changed 12 years ago by paulh

(In [20319]) Fix a crash in the program finder screen caused by not handling titles that start with 'An' correctly. Refs #6396.

comment:7 Changed 12 years ago by paulh

Resolution: fixed
Status: newclosed

(In [20320]) Merge [20319] from trunk.

Fix a crash in the program finder screen caused by not handling titles that start with 'An' correctly. Fixes #6396.

Note: See TracTickets for help on using tickets.