Opened 11 years ago

Closed 10 years ago

#6397 closed defect (fixed)

Watch Recordings menu slow due to preview grabbing

Reported by: obrienmd@… Owned by: Isaac Richards
Priority: minor Milestone: 0.22
Component: MythTV - General Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Using SVN 20270. Watch Recordings menu is extremely slow (especially when browsing shows with large numbers of episodes), and after looking at logs, it seems as though the delay is caused by Myth constantly grabbing previews from all episodes each time a show is selected in the left pane.

Thoughts? Let me know which info should be provided.

Change History (6)

comment:1 Changed 11 years ago by anonymous

Not a MythTV bug, it seems. NFSrooted frontend apparently is searching for (and not finding) thumbnails, which have been generated and show up fine on the MythTV server. They are in the same location on both machines (/myth/tv), will do more investigation as to why remote frontend cannot find and thus constantly initiates new preview grabs.

comment:2 Changed 11 years ago by anonymous

Hrm, looks like it may be a Myth issue after all. When I deselect "always stream recordings from backend", this issue goes away and all thumbnails are found perfectly. It seems that when this setting is checked, a remote frontend is unable to find thumbnails, even when they are mounted locally via NFS at the same mount point.

comment:3 Changed 11 years ago by anonymous

Is your actimeo set to 0 in your fstab?

If not nfs may simply not be telling mythtv that the file is there..

For reference these are my nfs mount options:

rsize=8192,wsize=8192,nosuid,soft,actimeo=0

comment:4 Changed 11 years ago by anonymous

It's not an NFS issue, because if I turn "stream recordings" off, and just play files as if they were "local" (but mounted over nfs), everything works great.

comment:5 Changed 10 years ago by sphery

If this issue is still occurring, please check the clock time on both the frontend and backend systems. If the clocks disagree, it will cause this issue. (You should also get a warning on frontend start if the frontend's clock is >20s different from the backend's.)

comment:6 Changed 10 years ago by sphery

Milestone: unknown0.22
Resolution: fixed
Status: newclosed

This should have been fixed by the background loading of preview images and the frontend preview image caching changes that went in shortly before 0.22 was released.

Note: See TracTickets for help on using tickets.