Opened 12 years ago

Closed 12 years ago

#6412 closed defect (fixed)

mythbackend segfaults

Reported by: mdrons@… Owned by: paulh
Priority: minor Milestone: unknown
Component: MythTV - General Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

mythbackend segfaults when frontends start a recording.

Attachments (4)

gdb.txt (28.9 KB) - added by anonymous 12 years ago.
myth.log (10.9 KB) - added by anonymous 12 years ago.
gdb.mvpmc.txt (28.8 KB) - added by mdrons@… 12 years ago.
gdb mythbackend with a mvpmc frontend
myth.mvpmc.log (11.0 KB) - added by mdrons@… 12 years ago.
myth log with a mvpmc frontend

Download all attachments as: .zip

Change History (11)

Changed 12 years ago by anonymous

Attachment: gdb.txt added

Changed 12 years ago by anonymous

Attachment: myth.log added

comment:1 Changed 12 years ago by paulh

Status: newinfoneeded_new

There's something wrong here. I dont find any reference to GET_CONNECTED_INPUTS anywhere in trunk.

What are you using to connect to the backend? Whatever it is it seems to be using a very old protocol.

comment:2 Changed 12 years ago by mdrons@…

I am using the windows Mythtv Player (from here http://www.sudu.dk/mythtvplayer/)

I will create the trace using mvpmc (http://www.mvpmc.org), it also causes the backend to segfault. I was using a trunk from about January 24th and it worked, using both types of frontends. I saw a few updates to the hdpvr that had been committed so I wanted to update.

Changed 12 years ago by mdrons@…

Attachment: gdb.mvpmc.txt added

gdb mythbackend with a mvpmc frontend

Changed 12 years ago by mdrons@…

Attachment: myth.mvpmc.log added

myth log with a mvpmc frontend

comment:3 Changed 12 years ago by robert.mcnamara@…

Neither of these is an official frontend, and neither is likely compatible with the current protocol... does this happen with a real, identical versioned Myth frontend?

comment:4 in reply to:  3 Changed 12 years ago by knightr@…

GET_CONNECTED_INPUTS was remove in changeset 15437 (http://svn.mythtv.org/trac/changeset/15437) according to http://www.mythtv.org/wiki/Protocol .

It looks like it might have been replaced by GET_FREE_INPUTS which was added at the same time but it possibly/probably doesn't behave in the same way...

MythTV Player is a very nice small frontend for MythTV and I can confirm that it does make Trunk segfault currently. It is also, unfortunately, no longer supported and in search of a new (lead) developer AFAIK...

Nick

comment:5 Changed 12 years ago by paulh

Status: infoneeded_newnew

Like Robert says neither of those players are supported so if they work then great if not then you need to ask their developers to fix them.

Even so mythbackend shouldn't crash if it receives some bad commands so I'll fix this particular problem shortly but you may still have problems with those player if they are not sending the correct commands.

comment:6 Changed 12 years ago by paulh

Owner: changed from Isaac Richards to paulh
Status: newassigned

comment:7 Changed 12 years ago by paulh

Resolution: fixed
Status: assignedclosed

(In [20297]) Check we have the correct number of items in the stringlist before trying to access them while parsing the FileTransfer? command. This stops the BE from aborting if a naughty player should send it a malformed FileTransfer? command. Fixes #6412.

Note: See TracTickets for help on using tickets.