Opened 11 years ago

Closed 11 years ago

#6415 closed defect (invalid)

Mythfrontend crashes after playing a recorded video, exiting and pressing the back button

Reported by: bigwoof1234@… Owned by: Isaac Richards
Priority: minor Milestone: 0.21.1
Component: MythTV - General Version: 0.21-fixes
Severity: medium Keywords: mythfrontend segfault
Cc: Ticket locked: no

Description

I'm using 0.21.svn20090401-0.0 (from debian-multimedia). this bug occurred fairly recently (introduced in the last 3 updates from debian-multimedia).

if you go to your recordings and press the back button on the remote (equivalent to escape on the keyboard), everything is fine and you will return to the previous screen.

but if you play something and return, and then press the back button, mythfrontend will crash with a segmentation fault. this is highly repeatable for me. just do the following, play a recording show, press back (to exit the playback of the recording), and press back again (to return to the main screen) => mythtvfrontend will segfault.

I've attached the gdb backtrace of the segfault.

the bug is irritating but not really that critical yet.

Attachments (2)

bt.txt (1.9 KB) - added by bigwoof1234@… 11 years ago.
gdb backtrace of the segmentation fault
bt-debug.txt (25.0 KB) - added by taco_mel 11 years ago.
Backtrace with debug symbols

Download all attachments as: .zip

Change History (10)

Changed 11 years ago by bigwoof1234@…

Attachment: bt.txt added

gdb backtrace of the segmentation fault

Changed 11 years ago by taco_mel

Attachment: bt-debug.txt added

Backtrace with debug symbols

comment:1 Changed 11 years ago by taco_mel

I am seeing this same issue with Ubuntu Jaunty (all latest updates) with 0.21-fixes SVN 19661 (from the repo) and my own compile with debug symbols from SVN 20310. Please note, I am using the proprietary nvidia drivers, because without them mythfrontend segfaults (Ubuntu bug 341898).

Attached is a full backtrace with debug symbols enabled.

comment:2 Changed 11 years ago by stuartm

Component: MythTV - User Interface LibraryMythTV - General
Owner: changed from stuartm to Isaac Richards
Status: newassigned

comment:3 Changed 11 years ago by anonymous

hi, i also get segmentation fault when exiting from playing video, see https://bugs.launchpad.net/mythbuntu/+bug/366002

comment:4 Changed 11 years ago by taco_mel

I can confirm that removing 'pulseaudio' has caused this problem to go away for me. http://ubuntuforums.org/showthread.php?t=1139782&page=2

comment:5 Changed 11 years ago by bigwoof1234

interesting. I run debian unstable. let me see if removing pulseaudio fixes the problem on debian.

comment:6 Changed 11 years ago by danielk

Status: assignedinfoneeded

Does this still happen with 0.21-fixes configured and compiled with libpulse-dev installed?

comment:7 Changed 11 years ago by taco_mel

My compile machine was lacking libpulse-dev so I installed it. Your suspicion was correct -- I am NOT experiencing the crash anymore with stuff compiled after installing libpulse-dev. (I compile on a separate machine and of course I do not have libpulse-dev on my frontend machine, and of course, I don't need it there.)

Since I and others had the same problem with the mythtv packages supplied with jaunty, I would suspect their compile environment was/is similarly broken.

In any case, maybe the configure script needs to check to see if the necessary dependency is there? But other than that, this issue is resolved at least for me. Thanks!

comment:8 Changed 11 years ago by Dibblah

Resolution: invalid
Status: infoneededclosed

This is a pulseaudio / packaging issue.

Note: See TracTickets for help on using tickets.