Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#6441 closed defect (invalid)

Recording without guide data fails to add split recordings to the recording table

Reported by: dmathog@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - Recording Version: 0.21-fixes
Severity: medium Keywords: nuv split half hour
Cc: Ticket locked: no

Description

I am using jyavenard's repository, currently mine is at 0.21.0+fixes20277-openglvdpau-0ubuntu3. My system has an SAA7130 analog capture card and I sometimes use it to record from an analog camcorder by creating a channel in mythtv and then doing a manual record. This works fine except that it splits NUV files at every half hour interval. For instance, for a recording which runs continuously from 6:45->7:45, the first NUV file will span 6:45 ->7:00, the second 7:00->7:30, and the final one 7:30->7:45. This wouldn't be a problem if Mythtv kept track of these, but it does not. Only the initial file shows up under "Watch Recordings", and the latter files are automatically deleted after a while (a day?) in normal operation. If there is a switch in setup to configure this I have yet to locate it. Even if there is such a switch, Mythtv should not lose the latter files.

Change History (8)

comment:1 Changed 11 years ago by sphery <mtdean@…>

This is as designed. MythTV automatically splits LiveTV at the top of and half past the hour when no guide data is present.

You need to use Manual Recording schedules. See http://www.gossamer-threads.com/lists/mythtv/users/284890#284890 and http://www.gossamer-threads.com/lists/mythtv/users/232857#232857 .

comment:2 Changed 11 years ago by Rob Smith

Resolution: invalid
Status: newclosed

comment:3 Changed 11 years ago by dmathog@…

It isn't the file splitting per se that is the bug. The bug is that only the first of the files created is entered in "Watch Recording" list. Consequently within Myth there is no way to watch the later parts of the recording, and the program loses track of the files to such an extent that it later deletes them automatically. THAT is the bug. I mean, is it not utterly counterproductive for MythTV to split the file, continue recording, and yet provide no means to watch or manipulate those parts of the recording?

comment:4 Changed 11 years ago by Rob Smith

Resolution: invalid
Status: closednew
Summary: mythttv capture from analog camcorder splits NUV files on the half hourRecording without guide data fails to add split recordings to the recording table

Please see if you can reproduce without using unsupported patches

comment:5 Changed 11 years ago by Rob Smith

Status: newinfoneeded_new

comment:6 Changed 11 years ago by sphery <mtdean@…>

The additional "parts" of the show (really, additional shows) are actually in MythTV. They--unlike the up-to-30-minute "program" you told it to record--are in the LiveTV recording group. Change your filter to include LiveTV and you'll see them.

The only reason the first part of the recording is not LiveTV is because you explicitly moved it from the LiveTV recording group by pushing R while watching LiveTV.

Again, you're doing the whole recording-from-"other"-sources thing wrong. Use Manual Recordings as described in the linked posts above (or, better, use some other application that's designed for that kind of thing).

And, in the future, starting with a question to mythtv-users list would be a great way to find out how things are supposed to work and how best to do what you're trying to do--or, even if some behavior you're seeing is actually a bug.

comment:7 Changed 11 years ago by Rob Smith

Resolution: invalid
Status: infoneeded_newclosed

comment:8 in reply to:  7 Changed 11 years ago by anonymous

Replying to kormoc:

"The only reason the first part of the recording is not LiveTV is because you explicitly moved it from the LiveTV recording group by pushing R while watching LiveTV."

Exactly, and all the other pieces should have been moved out too. The bug is that the "R" does not apply to the later pieces. How could that not be a bug? Invert the logic, why would an end user ever want to move just the first part of such a recording out of LiveTV? Or is the end user supposed to come back every half hour and hit R for each subsequent piece?

Sometimes one does not have the option of setting manual record because the end time is not known ahead of time. In this case I was converting some video my daughter had made, and not having watched it before, I had no idea when it would end.

I agree that Myth does not work well for this application. Presently there is a keyboard on my Myth machine, and since first stumbling over this issue I bave been using mencoder instead. (That had the added bonus that the result was an AVI and not a NUV.) But once the keyboard comes off (it's a DVR for the living room, not a general purpose computer), running anything other than MythTV is going to be very difficult, and we are still going to need to convert analog to digital from time to time.

Note: See TracTickets for help on using tickets.