Opened 11 years ago

Closed 11 years ago

#6448 closed defect (duplicate)

Prompt at end of recording causes playback to stop before end of file

Reported by: ryan.goat@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: unknown
Severity: medium Keywords: playback prompt at end of recording
Cc: Ticket locked: no

Description

I have seen this issue in SVN trunk for several weeks now. It seems to be related to the "prompt at end of recording" option in the setup:TV settings:playback menu (second page). If I have that feature enabled then the menu prompt will appear before the playback actually reaches the end of the recording. Sometimes it is several minuets before the end of the recording.

Even when mythtv is set to over record at the end of the schedule (upwards of 10 minuets) the end of recording prompt will appear before the end of the show. But the recording on the hard drive have the end of the show plus the extra 10 minuets.

Once I disabled the "prompt at end of recording" option mythtv seems to play the recordings to completion.

Attachments (2)

playback_20947.log (44.6 KB) - added by ryan.goat@… 11 years ago.
playback log showing end of recording menu appearing early (mpeg-2)
playback_20947.2.log (52.2 KB) - added by ryan.goat@… 11 years ago.
playback log showing end of recording menu appearing early (mpeg-2)

Download all attachments as: .zip

Change History (15)

comment:1 Changed 11 years ago by Dibblah

Status: newinfoneeded_new

Which specific revision of trunk are you running?

comment:2 Changed 11 years ago by ryan.goat@…

Trunk 20344.

Also I failed to mention that this machine records from a hauppauge HD=PVR. So all the recordings are in H.264 And the playack is through Nvidia VDPAU.

comment:3 Changed 11 years ago by laga

Does this problem still exist with current trunk? A few things have changed which could affect this problem - I assume it's related to the frame counting troubles with H264 files.

comment:4 Changed 11 years ago by ryan.goat@…

Thanks for dredging this ticket back to the front. I will check current trunk this weekend and get back to you.

comment:5 Changed 11 years ago by ryan.goat@…

trunk 20931 with patches from tickets:
http://svn.mythtv.org/trac/ticket/6243
http://svn.mythtv.org/trac/ticket/6719
http://svn.mythtv.org/trac/ticket/6611
http://svn.mythtv.org/trac/ticket/6602

The "prompt at end of recording" menu is working much better now. Playback continues past the scheduled end of the the show and goes through most of the "record past end of show" part. The "prompt at end of recording" menu now consistently appears 25-30 seconds before the end of the recording.

For example if I am watching a one hour show that I recorded 60 second extra in the beginning and 60 seconds extra at the end. Once the OSD reaches "1:01:32 of 1:01:59" it will show the "prompt at end of recording" menu.

Experimenting on another system with mpeg-2 recordings (trunk 20947 no patches) shows the "prompt at end of recording" menu appearing at "1:01:57 of 1:01:59". The extra 2 seconds are still there in the recording. I can get them to play if I press 'Esc' at the "prompt at end of recording" menu.

comment:6 Changed 11 years ago by laga

Can you please try to get a playback log using -v important,general,playback and post that as an attachment?

Changed 11 years ago by ryan.goat@…

Attachment: playback_20947.log added

playback log showing end of recording menu appearing early (mpeg-2)

comment:7 Changed 11 years ago by ryan.goat@…

Sorry I made the log wrong. Hold on. . .

Changed 11 years ago by ryan.goat@…

Attachment: playback_20947.2.log added

playback log showing end of recording menu appearing early (mpeg-2)

comment:8 Changed 11 years ago by robertm

Status: infoneeded_newnew

comment:9 Changed 11 years ago by ryan.goat@…

FYI,

Recompiled trunk (21651) after applying: http://svn.mythtv.org/trac/ticket/6148

I see no change for this bug (it still fails the same way).

-Ryan

comment:10 Changed 11 years ago by anonymous

Have you tried the patch at http://svn.mythtv.org/trac/ticket/6974

comment:11 in reply to:  10 Changed 11 years ago by gigem

Replying to anonymous:

Have you tried the patch at http://svn.mythtv.org/trac/ticket/6974

I have tried that patch and it did not help the prompt at end of recording issue for me.

comment:12 Changed 11 years ago by ryan.goat@…

quote:

Have you tried the patch at http://svn.mythtv.org/trac/ticket/6974

Yea that is what I meant to say yesterday. I had too many tabs open and I copy/pasted the wrong URL.

The patch from 6974 doesn't help the "prompt at end of recording issue". The one I originally linked to (6148) doesn't even have a patch.

comment:13 Changed 11 years ago by sphery

Resolution: duplicate
Status: newclosed

Duplicate of #6974 .

Though the play-to-end.patch on #6974 does not solve the issue with the prompt, we can not decrease the margin we're using to check for the end of recording until play-to-end.patch is applied. Once play-to-end.patch is applied, mythtv-6974-IsNearEnd_margin_for_end_of_recording_prompt.patch (added to #6974 since you last tested) could be used to decrease the margin. However, Mark Spieth has commented that he may create a new patch that does away with the requirement for a margin check, which would truly play the recording to the end and would work much better--even with material where the IsNearEnd?() check is not very accurate.

Note: See TracTickets for help on using tickets.