Opened 11 years ago

Closed 11 years ago

#6450 closed defect (invalid)

Offer to remove $HOME/.ICEauthority to make mytharchive function properly

Reported by: philip@… Owned by: paulh
Priority: critical Milestone: 0.21.1
Component: Plugin - MythArchive Version: 0.21-fixes
Severity: high Keywords:
Cc: Ticket locked: no

Description

This bug has existed since at least 2007. I just discovered the following page. I always wondered why mytharchive just stopped working when I reinstalled my box.

All of my problems went away by simply removing the $HOME/.ICEauthority file. If this file is not removed mytharchive and the utilities that it uses simply DO not function properly at all and they error out. See the logs in here:

http://ubuntuforums.org/showthread.php?t=610856

Here is what I recommend:

When the GUI first loads the mytharchive screen have the code check for the existence of this file. If it finds it have the code prompt the user to delete it with the following dialog:

"On certain Linux distributions the presence of a .ICEauthority file can interfere with mytharchive functioning properly. Most users do not need a .ICEauthority file. Would you like MythArchive? to remove it for you so that it will function properly?"

Responses: No Yes, this time Yes, always remove it

If someone wants to dig a little deeper to figure out what the problem is that's fine. I'm sure removing the .ICEauthority file is something of a kludge but HEY it FIXES the problem and to the end user that's ALL they care about!

I'm running 19961 as packaged in Mythbuntu 9.04 Beta.

Change History (1)

comment:1 Changed 11 years ago by Dibblah

Resolution: invalid
Status: newclosed

This is not correct. The problem is that .ICEauthority is being repermissioned by someone running an application under root (or just other) credentials.

As such, this is not a Myth bug.

Also, this is a feature request without a patch.

Note: See TracTickets for help on using tickets.