Opened 11 years ago

Closed 10 years ago

#6454 closed defect (fixed)

frame sync error

Reported by: elkin@… Owned by: Isaac Richards
Priority: major Milestone: 0.22
Component: MythTV - General Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi, testing trunk I found, that on some files with ac3 audio the preview making crashes with the following error. It leaves the cpu at 100% with a rogue mythbackend running that has to be killed by hand.

2009-04-12 19:40:29.804 mythbackend version: trunk [Unknown] www.mythtv.org                           
2009-04-12 19:40:29.805 Using runtime prefix = /usr                                                   
2009-04-12 19:40:29.805 Empty LocalHostName.                                                          
2009-04-12 19:40:29.805 Using localhost value of elkin                                                
2009-04-12 19:40:29.812 New DB connection, total: 1                                                   
2009-04-12 19:40:29.817 Connected to database 'mythconverg' at host: localhost                        
2009-04-12 19:40:29.817 Closing DB connection named 'DBManager0'                                      
2009-04-12 19:40:29.818 Connected to database 'mythconverg' at host: localhost                        
2009-04-12 19:40:29.823 Current Schema Version: 1232                                                  
2009-04-12 19:40:29.827 New DB connection, total: 2                                                   
2009-04-12 19:40:29.828 Connected to database 'mythconverg' at host: localhost                        
2009-04-12 19:40:29.829 New DB connection, total: 3                                                   
2009-04-12 19:40:29.830 Connected to database 'mythconverg' at host: localhost                        
2009-04-12 19:40:29.952 AFD: Opened codec 0xa23500, id(MPEG4) type(Video)                             
2009-04-12 19:40:29.952 AFD: codec AC3 has 2 channels                                                 
2009-04-12 19:40:29.953 AFD: Opened codec 0xa22710, id(AC3) type(Audio)                               
2009-04-12 19:40:29.998 [mpeg4 @ 0x7f1e4cc1f2c0]warning: first frame is no keyframe                   
2009-04-12 19:40:30.006 [ac3 @ 0x7f1e4cc1f2c0]frame sync error                                        
2009-04-12 19:40:30.006 [ac3 @ 0x7f1e4cc1f2c0]frame sync error                                        
2009-04-12 19:40:30.006 [ac3 @ 0x7f1e4cc1f2c0]frame sync error                                        
2009-04-12 19:40:30.006 [ac3 @ 0x7f1e4cc1f2c0]frame sync error                                        
2009-04-12 19:40:30.007 [ac3 @ 0x7f1e4cc1f2c0]frame sync error                                        
2009-04-12 19:40:30.007 [ac3 @ 0x7f1e4cc1f2c0]frame sync error                                        
2009-04-12 19:40:30.007 [ac3 @ 0x7f1e4cc1f2c0]frame sync error                                        
2009-04-12 19:40:30.007 [ac3 @ 0x7f1e4cc1f2c0]frame sync error        

Change History (7)

comment:1 Changed 10 years ago by anonymous

I get that too, every once in a while, from recordings made with a hdhomerun.

comment:2 Changed 10 years ago by databubble

I can provide a little more detail. The messages are coming from mythcommflag. At the moment I have three mythcommflag jobs running that are all reporting the same messages. My mythbackend.log from today alone is over 4 million lines long. I have two 3GHz cores that have been maxed for hours just generating these error messages. Interestingly, two of them seem to be working on the same recording:

UID PID PPID C STIME TTY TIME CMD mythtv 29013 29012 2 08:15 ? 00:04:55 /usr/bin/mythcommflag -j 68 -V 3 mythtv 30779 30778 1 09:32 ? 00:01:41 /usr/bin/mythcommflag -j 68 -V 3 mythtv 30782 30781 1 09:32 ? 00:01:22 /usr/bin/mythcommflag -j 71 -V 3

I'm letting them run as an experiment... just to see whether it eventually completes, and if so, whether the commercial flagging actually works.

The recordings are coming from a HD-PVR, and the mythcommflag troubles started when I switched all audio to record as AC3. Currently at trunk 20743... which is as high as it goes at the moment.

Basically, mythcommflag appears to be broken and is now the limiting factor on how much I can record.... of course, if it keeps happening I'll have to turn off commercial flagging.

comment:3 Changed 10 years ago by robert.mcnamara@…

Others have found that this issue is caused by compiling myth against liba52/using liba52 AC3 decode. If you are doing so, you should disable it.

comment:4 Changed 10 years ago by databubble

Hi Robert,

Thanks for your response. I'm not consciously compiling against liba52... in fact I´m not adding any additional libraries at all, apart from enabling AAC through configure, as follows:

./configure --prefix=/usr --enable-proc-opt --disable-audio-oss --disable-audio-arts --disable-audio-jack --disable-joystick-menu --disable-hdhomerun --disable-xvmcw --enable-libfaad --enable-vdpau --disable-directfb --enable-opengl-vsync

and then I simply do a "make" and "checkinstall." no additional libraries, no special tricks. Trunk 20745.

Without enabling libfaad, I get error messages as follows:

 AFD: Opened codec 0x19a59a0, id(H264) type(Video)
2009-06-25 15:46:48.592 AFD: codec AAC has 2 channels
2009-06-25 15:46:48.592 AFD Error: Could not open codec 0x19a4a00, id(AAC) type(Audio) aborting. reason -1
2009-06-25 15:46:48.592 NVP(0): Disabling Audio, params(-1,-1,-1)

and I still get the frame sync errors in mythcommflag, anyway.... so it doesn't have anything to do with AAC

Output from configure:

# Basic Settings                                 
Compile type              release                
Compiler cache            yes                    
DistCC                    no                     
qmake                     /usr/bin/qmake-qt4     
install prefix            /usr                   
runtime prefix            /usr                   
CPU                       x86_64 (model name    : AMD Athlon(tm) 64 X2 Dual Core Processor 6000+)
big-endian                no                                                                     
yasm                      no                                                                     
MMX enabled               yes                                                                    
CMOV enabled              yes                                                                    
CMOV is fast              yes                                                                    

# Input Support
Joystick menu             no
lirc support              yes
Video4Linux sup.          yes
ivtv support              yes
HR-PVR support            yes
FireWire support          yes
DVB support               yes [/usr/include]
HDHomeRun support         no                
IPTV support              yes               

# Sound Output Support
PulseAudio support        yes
OSS support               no 
ALSA support              yes
aRts support              no 
JACK support              no 
libfftw3 support          no 

# Video Output Support
x11 support               yes
xrandr support            yes
xv support                yes
XvMC support              yes
XvMC VLD support          yes
XvMC pro support          no 
XvMC libs                 -lchromeXvMC
VDPAU support             yes         
OpenGL video              yes         
OpenGL vsync              yes         
DirectFB                  no          
Fribidi formatting        no          
MHEG support              yes         

# Misc Features
multi threaded libavcodec yes
Frontend                  yes
Backend                   yes

# Bindings
bindings_perl             yes
bindings_python           yes

Creating libs/libmythdb/mythconfig.h and libs/libmythdb/mythconfig.mak

WARNING: When using --enable-proc-opt you must include the
         output of ./configure along with any bug report.


comment:5 Changed 10 years ago by laga

Status: newinfoneeded_new

Can you retry with current trunk? We've had a ffmpeg resync which might have helped.

comment:6 Changed 10 years ago by databubble

Under 20842 I am no longer seeing any sync errors, thanks. The resync seems to have solved the problem, and commflag is working fine.

Good work.

comment:7 Changed 10 years ago by Janne Grunau

Resolution: fixed
Status: infoneeded_newclosed

apparently fixed by ffmpeg sync in [20797]

Note: See TracTickets for help on using tickets.