Opened 10 years ago

Closed 9 years ago

#6468 closed defect (duplicate)

Compile error videoout_directfb.cpp

Reported by: Bjorn Gustafsson <bjorne-g@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I get:

videoout_directfb.cpp: In member function ‘bool DirectfbData::CreateBuffers?(VideoBuffers?&, DFBSurfaceDescription)’: videoout_directfb.cpp:145: error: cannot convert ‘DirectResult?’ to ‘DFBResult’ in assignment videoout_directfb.cpp:202: error: cannot convert ‘DirectResult?’ to ‘DFBResult’ in assignment videoout_directfb.cpp: In member function ‘void DirectfbData::DeleteBuffers?(VideoBuffers?&)’: videoout_directfb.cpp:248: error: cannot convert ‘DirectResult?’ to ‘DFBResult’ in assignment videoout_directfb.cpp: In function ‘DFBEnumerationResult layer_cb(unsigned int, DFBDisplayLayerDescription, void*)’: videoout_directfb.cpp:1147: error: cannot convert ‘DirectResult?’ to ‘DFBResult’ in assignment

when building mythtv.

svn info: URL: http://svn.mythtv.org/svn/trunk/mythtv Repository Root: http://svn.mythtv.org/svn Repository UUID: 7dbf422c-18fa-0310-86e9-fd20926502f2 Revision: 20412

Latest Debian/testing as per 2009-04-18

Any hints?

Regards,

Björne

Change History (2)

comment:1 Changed 10 years ago by cybernard

I got the same type of errors.

comment:2 Changed 9 years ago by robertm

Resolution: duplicate
Status: newclosed

Dupe of #7351.

Note: See TracTickets for help on using tickets.