Opened 12 years ago

Closed 11 years ago

#6470 closed enhancement (fixed)

Fulltext search inside the filter-dialog from the videobrowser of mythvideo

Reported by: Markus Schulz <msc@…> Owned by: robertm
Priority: minor Milestone: unknown
Component: Plugin - MythVideo Version: head
Severity: low Keywords: fulltext search
Cc: Ticket locked: no

Description

With this patch, you can do fulltext search inside: title/subtitle/plot and combine this with season/episode searches. for example: "rock 1x" will list all episodes from with season == 1 containing "rock" in title/subtitle/plot. "1x10" will list all 10-episodes from season 1. ...

This patch needs the ticket #6346 and using the terra theme (only there was the filter dialog available).

Screenshot: http://www.tastatur-junkie.de/~nias/fulltextsearch.jpg

Attachments (5)

fulltextsearch.diff (25.4 KB) - added by Markus Schulz <msc@…> 12 years ago.
patch@20413
fulltextsearch_v2.diff (36.3 KB) - added by Markus Schulz <msc@…> 12 years ago.
V2 with support for all themes via default/default-wide filter-screen
fulltextsearch_v3.diff (44.9 KB) - added by Markus Schulz <msc@…> 12 years ago.
V3 with support for insertdatum based search
fulltextsearch_v4.diff (45.9 KB) - added by Markus Schulz <msc@…> 11 years ago.
new Version
filters_background.png (6.7 KB) - added by Markus Schulz <msc@…> 11 years ago.
separate version of filters_background.png from terra theme

Download all attachments as: .zip

Change History (16)

Changed 12 years ago by Markus Schulz <msc@…>

Attachment: fulltextsearch.diff added

patch@20413

Changed 12 years ago by Markus Schulz <msc@…>

Attachment: fulltextsearch_v2.diff added

V2 with support for all themes via default/default-wide filter-screen

comment:1 Changed 12 years ago by Markus Schulz <msc@…>

now all themes are supported. i've changed default/default-wide video-iu.xml to support the fulltext input.

Changed 12 years ago by Markus Schulz <msc@…>

Attachment: fulltextsearch_v3.diff added

V3 with support for insertdatum based search

comment:2 Changed 12 years ago by Markus Schulz <msc@…>

New version. I've added a insertdate into videometadata table (New Mythvideo DB-Schema Version!) with default value CURRENT_TIMESTAMP.

Now you can search with -[0-9]+[dmw] for: -Xd == insertdate is maximum X days behind -Xw == insertdate is maximum X weeks behind -Xm == insertdate is maximum X months behind

this can be combined with the existing searches (episode, plot,..)

comment:3 Changed 12 years ago by r.d.vaughan@…

Markus,

The only way I could get the v2 patch to apply was to edit all the "a/mythplugins/..." and "b/mythplugins/..." to be just "mythplugins/...". After that the patch applied clean.

This may just be me, but I have a number of other patches applied without issue.

With the modifications I made to the patch I get a clean compile and the patch works as advertised.

An odd behavior is that when I can start typing a series name as soon as I have to type a space the on screen keyboard pops up and it must be used for any space character. An esc key must be hit to get rid of the on screen keyboard. This is most annoying, can anything be done to change that behavior without messing up non-keyboard users?

Thanks for adding this enhancement I really like it.

comment:4 in reply to:  3 ; Changed 12 years ago by Markus Schulz <msc@…>

Replying to r.d.vaughan@rogers.com:

Markus,

The only way I could get the v2 patch to apply was to edit all the "a/mythplugins/..." and "b/mythplugins/..." to be just "mythplugins/...". After that the patch applied clean.

use: patch -p1 < FILE this strips automatically the first element.

An odd behavior is that when I can start typing a series name as soon as I have to type a space the on screen keyboard pops up and it must be used for any space character. An esc key must be hit to get rid of the on screen keyboard. This is most annoying, can anything be done to change that behavior without messing up non-keyboard users?

iirc this was the default behaviour for _each_ textedit (if you enabled the osd keyboard) the space key shows the OSD-Keyboard window. this is not caused by this patch here, sorry. If you have a real keyboard you can disable the OSD-keyboard generally.

comment:5 in reply to:  4 Changed 12 years ago by paulh

Replying to Markus Schulz <msc@antzsystem.de>:

An odd behavior is that when I can start typing a series name as soon as I have to type a space the on screen keyboard pops up and it must be used for any space character. An esc key must be hit to get rid of the on screen keyboard. This is most annoying, can anything be done to change that behavior without messing up non-keyboard users?

iirc this was the default behaviour for _each_ textedit (if you enabled the osd keyboard) the space key shows the OSD-Keyboard window. this is not caused by this patch here, sorry. If you have a real keyboard you can disable the OSD-keyboard generally.

I just remove SPACE from the SELECT keybinding and use RETURN for SELECT (it's already bound that way by default anyway). That way you get the best of both worlds.

comment:6 Changed 11 years ago by robertm

Status: newinfoneeded_new

Hi Markus,

I am fine with having a freeform text filter-- since the MythVideo? main window now has the (consistent, MythUI) incremental search, I would shy away from referring to what you have here as a "fulltext search." What I think it really is is a text filter, which is valuable and I'm okay with committing. So I'll ask the following:

  • Update the patch for current trunk.
  • Update the variable and function names to replace "fulltextsearch" with "textfilter" or similar.
  • Fix your theme patches to group labels with labels, and widgets with widgets, as all the others do.

Marking this infoneeded for now, direct discussion or questions to the dev list.

Changed 11 years ago by Markus Schulz <msc@…>

Attachment: fulltextsearch_v4.diff added

new Version

comment:7 Changed 11 years ago by Markus Schulz <msc@…>

New version includes the needed changes:

  • renamed fulltextsearch to textfiler
  • update to current trunk
  • regroup the lables and widgets in the theme-xmls

The Patch contains a binary file (updated filters_background.png from Terra). If needed (can svn apply git-binary patches?) i can upload it separately.

comment:8 Changed 11 years ago by robertm

Status: infoneeded_newnew

Hi Markus,

Go ahead and add the png as a separate attachment please.

comment:9 Changed 11 years ago by robertm

Owner: changed from Anduin Withers to robertm
Status: newassigned

Changed 11 years ago by Markus Schulz <msc@…>

Attachment: filters_background.png added

separate version of filters_background.png from terra theme

comment:10 Changed 11 years ago by robertm

Markus,

The Terra Background has some artifacts on the right edge dropshadow-- can you upload a clean copy? Thanks.

comment:11 Changed 11 years ago by robertm

Resolution: fixed
Status: assignedclosed

(In [21274]) Closes #6470. Patch by Markus Schulz to add a freeform text filter to the filter dialog. Also adds Metadata for date an item was added to your library. On top of the patch, I have added a browse mode by Date Added, and the MythUI text areas for this information. Terra, Graphite, and default themes updated to match. Information in the ticket on text fitler format, but it allows search by season and episode as well ie 'Lost 1x' will match all of season one of LOST.

Note: See TracTickets for help on using tickets.