Opened 10 years ago

Closed 10 years ago

#6481 closed defect (fixed)

VDPAU since 20325 black screen when no focus

Reported by: elkin@… Owned by: markk
Priority: trivial Milestone: 0.22
Component: MythTV - General Version: head
Severity: low Keywords: black screen VDPAU
Cc: Ticket locked: yes

Description

when watching a recording, if the player looses focus due to a program like skype, kopete or updatemanagers, the part that the message took stays black after it disapears. If you do an alt-tab to any other application leads to a fully black window. Audio still works and ESC gets you out. Playback works again if you start the recording again. Error only with VDPAU, no problem with the "standard" renderer. Before and at r20325 it still works... no relevant output in the logs.

My system: Mythbuntu trunk after r20325 on Jaunty. Nvidia 8600GT with 180.44 drivers (180.51 tested, but no change).

Change History (14)

comment:1 Changed 10 years ago by robert.mcnamara@…

Which particular revision after 20325 (140 revisions ago as of now) are you running? There have been multiple VDPAU related EPG and internal player fixes since then. Does this problem persist with the current revision?

comment:2 Changed 10 years ago by elkin@…

schould have been more precise: between 20325 and 403... those are the current mythbuntu weekly builds. Looking at the changes, there seem to be some that include adding a black background. But I am in no way a developer. thanks for looking into it.

comment:3 Changed 10 years ago by jheikkal@…

I'm using 20435 now and got same problem. Also when starting playback, screen flashes latest menu screen(from buffer?). Also if guide is show during playback, screen goes black. Only applies vdpau renderer. Worked pre 20325.

comment:4 Changed 10 years ago by anonymous

I've been seeing this problem since VDPAU was introduced. I have OSD_CAT displaying content on top of the VDPAU layer and it stays black. I haven't tested this, but my gut says this has something to do with:

Option "Composite" "Disable"

This is required for me to avoid tearing, but when I see tearing the black problem goes away.

comment:5 Changed 10 years ago by myth@…

I just confirmed that removing Option "Composite" "Disable" from xorg.conf fixes this (but brings back tearing). Not sure there's much we can do about it.

comment:6 Changed 10 years ago by anonymous

The latest drivers in the 185.xx series from nVidia add vSync to blank to the blit path. If you're not using the latest drivers with VDPAU, you should.

comment:7 Changed 10 years ago by elkin@…

just installed 185.19 and it does _not_ fix the problem... rolling back to r20325 does.

comment:8 Changed 10 years ago by myth@…

185.19 does not fix it for me either, but neither does rolling back to 20325. Mine must be something else.

comment:9 in reply to:  8 Changed 10 years ago by anonymous

Replying to myth@dermanouelian.com:

185.19 does not fix it for me either, but neither does rolling back to 20325. Mine must be something else.

Not true! It works if you enable composite and use 185.19 drivers. No tearing in my test recordings.

comment:10 Changed 10 years ago by myth@…

Well, what I said *is* true, but I now understand what you're saying. The answer is to not use disable composite if you don't want this to happen (as I said), but you have to upgrade to the latest 185.xx driver to prevent tearing in this configuration.

comment:11 Changed 10 years ago by danielk

Owner: changed from Isaac Richards to markk
Priority: majortrivial
Severity: mediumlow
Status: newassigned
Ticket locked: set
Version: unknownhead

comment:12 Changed 10 years ago by markk

Ticket locked: unset

This is a known problem introduced with the new GuideGrid/?'TV Player Window' code and is not restricted to VDPAU; there are similar issues with Xv and XvMC. OpenGL embedding is broken as well.

Changing Nvidia driver versions will not help - the colorkey mask is either not being drawn or is being overpainted. For VDPAU disable the overlay (VDPAU_NVIDIA_NO_OVERLAY=1) as a temporary workaround (which may or may not introduce tearing depending on your driver version).

comment:13 Changed 10 years ago by markk

Ticket locked: set

comment:14 Changed 10 years ago by markk

Resolution: fixed
Status: assignedclosed

(In [20440]) Reinstate some event handling in the TV class that was removed in r20355. Tested with various profiles on 3 machines without issue and I can't see any logical reason not to add it back. Closes #6481 (although there is still an issue with OpenGL playback and embedded video).

Note: See TracTickets for help on using tickets.