Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6482 closed patch (fixed)

RTTI Link Error in Channel Scanner when not using DVB

Reported by: mythtv@… Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - DVB/ATSC Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When building revision 20436 without support for DVB I receive a link error from libs/libmythtv/channelscan/channelscan_sm.cpp.

The problem appears to be caused by line 168:

    DVBChannel *dvbchannel = dynamic_cast<DVBChannel*>(channel);

The RTTI information necessary for the dynamic_cast is unavailable because libs/libmythtv/dvbchannel.cpp is only compiled when DVB is enabled.

This problem was encountered using the osx-packager.pl script

Attachments (1)

rtti_link_error_r20436.patch (823 bytes) - added by mythtv@… 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by mythtv@…

comment:1 Changed 10 years ago by Nigel

Resolution: fixed
Status: newclosed

(In [20437]) Allow compilation when using_dvb isn't set, like on OS X. Closes #6482

comment:2 Changed 10 years ago by danielk

(In [20438]) Refs #6482. ifdef some DVB only code.

Note: See TracTickets for help on using tickets.