Opened 10 years ago

Closed 10 years ago

#6504 closed defect (fixed)

Blank screen after watching TV or recording

Reported by: anonymous Owned by: paulh
Priority: major Milestone: unknown
Component: MythTV - General Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

After a change introduced in revision [20440], after I exit watching TV or recordings, the screen is blank (black). If I use Alt-Tab to bring another window in front, the menu in mythfrontend reappears.

Revision [20439] was ok. Revisions [20440]-[20445] are not ok.

I have ATI Radeon HD 3650 graphics card, if that's important? I'm using Catalyst driver.

Change History (10)

comment:1 Changed 10 years ago by anonymous

Oops .. I meant to say that 20440 - 20455 (the latest) are not ok. (20445 was a typo.)

comment:2 Changed 10 years ago by paulh

I've had problems with [20440] myself but only if I use the Qt painter.

Which painter and which video renderer are you using?

comment:3 Changed 10 years ago by danielk

paulh, I don't know about the original reporter. But my experience is the same as yours. I think we may need to remove the eventFilter at the end of playback and then explicitly trigger an expose event.

The OpenGL UI renderer may actually only be working due to another bug that triggers excessive redraws. In trunk it sucks down considerable CPU (15-20%) when sitting idle.

comment:4 Changed 10 years ago by mythdev@…

I also experience a black screen at the end of a recording (either pressing stop, or the recording ends).

I am using the QT painter (VIA EPIA CLE266)

comment:5 Changed 10 years ago by Jarod Wilson

QT painter on Intel X3100 graphics also reproduces the problem.

comment:6 Changed 10 years ago by paulh

Owner: changed from Isaac Richards to paulh
Status: newaccepted

comment:7 Changed 10 years ago by paulh

Status: acceptedstarted

comment:8 Changed 10 years ago by paulh

(In [20471]) Fix a few window positioning problems reported with the playback screen after the changes to make it MythUI friendly. Only lightly tested there are way too many combinations of settings to test them all. Fixes #6487, #6508. Refs #6504.

comment:9 in reply to:  3 Changed 10 years ago by paulh

Replying to danielk:

paulh, I don't know about the original reporter. But my experience is the same as yours. I think we may need to remove the eventFilter at the end of playback and then explicitly trigger an expose event.

Can you still reproduce this after [20471]?

The OpenGL UI renderer may actually only be working due to another bug that triggers excessive redraws. In trunk it sucks down considerable CPU (15-20%) when sitting idle.

Are you using the GANT theme? That theme does use a lot of CPU because of the fade effect on the logo on the left hand side of the background which does cause the screen to be redawn 70 times a second. I don't see it using any other theme though.

comment:10 Changed 10 years ago by danielk

Resolution: fixed
Status: startedclosed

paulh, I can no longer reproduce this after [20471], marking it fixed.

PS I'm using MythCenter? not G.A.N.T. but I think the high CPU usage of the mythfrontend is an unrelated issue.

Note: See TracTickets for help on using tickets.