Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#6509 closed defect (worksforme)

Closed Captions Don't Work on Frontend Machine

Reported by: jdeslip@… Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.21-fixes
Severity: low Keywords:
Cc: Ticket locked: no

Description

Hi. I have mythbox with a backend/frontend setup to use VBI closed captions and it works great both on live tv and recordings when I am watching on this machine.

However, I have laptops that I have just frontends on and the closed captions don't work. I can turn them on in the menu when playing a video but nothing shows up. I have fiddled with every setting in the OSD settings, but nothing works.

Change History (7)

comment:1 Changed 11 years ago by danielk

Resolution: invalid
Status: newclosed

You need to run mythtv-setup and enable captions.

comment:2 Changed 11 years ago by jdeslip@…

I have run mythtv-setup on the backend and have enabled VBI. When I playback media on the backend (which also has a frontend) captions work great.

Are you saying I also have to run mythtv-setup on the other frontends?? VBI-captions do show up as menu option during playback on these frotends but after I turn them on, nothing happens. Can you reopen this, I don't have the authority apparently.

comment:3 Changed 11 years ago by danielk

Milestone: 0.21.1unknown
Priority: majorminor
Resolution: invalid
Severity: mediumlow
Status: closednew

[Note: reopened after following discussion in mailing list. Bug still not 3rd party confirmed.]

comment:4 Changed 11 years ago by jdeslip@…

I have a bit of an update on the CC captions which work only on the joint backend/frontend machine and not on the remote frontends.

I have actually discovered that it works on some of the channels but not others on the frontend. I live in the Bay Area, and one of the local stations has a 4-1 and 4-2 channel. Both are digital, but 4-1 looks like the old low res analogue and 4-2 is in HD. Captions correctly work on 4-1 on all my machines, but they only work on 4-2 on the joint backend/frontend. For 4-2, the captions say they are turned on but nothing displays on my two laptops acting as frontends. They don't work on ABC/FOX on my frontend laptops, but they do work on PBS (which is HD).

Does this give anyone an idea of what is wrong? I'd like to get it working for all channels. Sorry for not making this discovery sooner.

comment:5 Changed 10 years ago by stuartm

Owner: changed from Isaac Richards to danielk
Status: newassigned

comment:6 Changed 10 years ago by danielk

Resolution: worksforme
Status: assignedclosed

Works for me with trunk. Note: I recently made a change to detect captions for which there are no caption descriptors. If this works for you with trunk and not 0.22-fixes I can backport this feature as a bug fix, but I'm currently going on the assumption that this is rare (I've only seen this on the PBS kids stream.)

comment:7 Changed 10 years ago by sphery

Users who have problems with this may find that things work after shutting down all MythTV frontends and backends and executing the following:

mysql -umythtv -p mythconverg -e "DELETE FROM settings WHERE value LIKE '%VBIFormat';"

then restarting.

Note: See TracTickets for help on using tickets.