Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#652 closed defect (worksforme)

SVN 7872 OSD not scaling properly

Reported by: anonymous Owned by: danielk
Priority: minor Milestone: 0.19
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

My X screen size is 576x432. My OSD used to be sized so that it was just narrower than the screen. I updated from 7739 to 7872 today and now the OSD is wider than the screen, like it is looking somewhere else to see what size it should be.

Change History (8)

comment:1 Changed 14 years ago by danielk

Milestone: 0.19
Owner: changed from Isaac Richards to danielk

Oscar reported something similar, except that his was narrower than the screen and offset to the right.

comment:2 Changed 14 years ago by Oscar Carlsson

With current SVN I'm not seing this anymore, dunno if it was fixed by a changeset (haven't seen anthing that should have touched that), a clean build or a restart of X. Only mode where the OSD doesn't fill now is 4:3, where it only fills the video area, not the screen area with black bars at the left and right hand side (widescreen).

comment:3 Changed 14 years ago by danielk

The blended OSD's will only ever fill the video area, because they are blended with the video. Only the chromakey OSD can extend past the video area.

Oscar, I'll consider your problem a seperate and solved problem.

Anon, can you do a "make distclean; ./configure --prev; make" before reinstalling, and tell me if that makes it work?

comment:4 Changed 14 years ago by anonymous

No, I still have the same problem.

comment:5 Changed 14 years ago by danielk

Resolution: worksforme
Status: newclosed

I can't reproduce this with a 576x432 resolution with either a 720x480 video or a 1280x720 video.

What OSD theme are you using?

Are you using overscan? If so [7996] should adjust for this.

Are you using a letterbox mode ("aspect override")? Which one?

I'm closing this as a "worksforme", but if the problem persists please answer those questions and attach the frontend log after changing the "#if 0" on about line 809 in videooutbase.cpp to "#if 1". Then reopen the ticket.

comment:6 Changed 14 years ago by anonymous

I think this is related to #667 because as commits are made against it, it changes, but doesn't fix, my OSD. I've made a post there.

To answer your questions:

OSD Theme: Titivillus-OSD Overscan: Vertical and horizontal are +5% Aspect Override: Off

I use tahoma.ttf for my OSD font and font size small if that affects anything. I have tried other settings here, but that makes no difference.

Other OSD themes, don't fall off the right edge, but they all seem to have fonts that are too wide.

What args should I pass to mythfrontend -v for the log you want?

comment:7 Changed 14 years ago by danielk

(In [8027]) References #652.

Make the overscan adjustment a little more precise for OSD placement. I tested with up to +3% last time, this time I upped it to +10%.

comment:8 Changed 14 years ago by anonymous

8021 under #667 fixed the fonts and #8027 here fixed the OSD running off the right side of screen. This is closed as far as I'm concerned.

Note: See TracTickets for help on using tickets.