Opened 11 years ago

Closed 11 years ago

#6565 closed defect (worksforme)

mythfilldatabase crashed with SIGSEGV in MythContext::ClearSettingsCache()

Reported by: mrand Owned by: stuartm
Priority: minor Milestone: 0.21.1
Component: MythTV - Mythfilldatabase Version: 0.21-fixes
Severity: medium Keywords: mythfilldatabase SIGSEGV ClearSettingsCache
Cc: Ticket locked: no

Description

Multiple reports of this, each with register and trace dumps

#0  0x00000000025c9b40 in ?? ()
#1  0x00007fbd184fb57b in MythContext::ClearSettingsCache (this=0x25a8560, 
    myKey=
      {static null = {static null = <same as static member of an already seen type>, d = 0x2476480, static shared_null = 0x2476480}, d = 0x7fbd0e6113d0, static shared_null = 0x2476480}, newVal=
      {static null = {static null = <same as static member of an already seen type>, d = 0x2476480, static shared_null = 0x2476480}, d = 0x7fbd0e6113c0, static shared_null = 0x2476480}) at mythcontext.cpp:1865
No locals.
#2  0x00007fbd1850d6e3 in MythContext::readyRead (this=0x25a8560, 
    sock=<value optimized out>) at mythcontext.cpp:3347
	strlist = {<QValueList<QString>> = {sh = 0x25e4460}, <No data fields>}
	prefix = {static null = {
    static null = <same as static member of an already seen type>, 
    d = 0x2476480, static shared_null = 0x2476480}, d = 0x26630f0, 
  static shared_null = 0x2476480}
	message = {static null = {
    static null = <same as static member of an already seen type>, 
    d = 0x2476480, static shared_null = 0x2476480}, d = 0x25ccb00, 
  static shared_null = 0x2476480}
#3  0x00007fbd185501e5 in readyReadThread_iffound (sock=0x25e3e50)
    at mythsocket.cpp:743
No locals.
#4  0x00007fbd1855171e in MythSocket::readyReadThread () at mythsocket.cpp:908
	it = {<QGListIterator> = {list = 0x7fbd188f0920, 
    curNode = 0x26631c0}, <No data fields>}
	it = {<QGListIterator> = {list = 0x7fbd188f0920, 
    curNode = 0x0}, <No data fields>}
	rval = <value optimized out>
	rfds = {fds_bits = {256, 0 <repeats 15 times>}}
	sock = (MythSocket *) 0x25e3e50
	maxfd = 10
#5  0x00007fbd14bab3ba in start_thread () from /lib/libpthread.so.0
#6  0x00007fbd1416dfcd in clone ()
    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
No locals.
#7  0x0000000000000000 in ?? ()

Attachments (1)

ThreadStacktrace.txt (15.7 KB) - added by mrand 11 years ago.
ThreadStacktrace?.txt

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by mrand

Attachment: ThreadStacktrace.txt added

comment:1 Changed 11 years ago by robert.mcnamara@…

If this is the usual report of a mythfilldatabase segfault, it's a Qt bug (with Qt 3.3), not a Myth one. It's also harmless.

comment:2 Changed 11 years ago by stuartm

Milestone: unknown0.21.1
Resolution: worksforme
Status: newclosed

Backtrace isn't much use, the first thread is a dead end, second leads me to suggest a file-system corruption related dump but only because I can't think of anything better. Try a fsck and if you can still reproduce then install the qt-debugging symbols before generating a new backtrace.

Note: See TracTickets for help on using tickets.