Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6585 closed defect (fixed)

Program Finder highlighted selection not in the focus bar

Reported by: newbury@… Owned by: paulh
Priority: minor Milestone: 0.22
Component: MythTV - User Interface Library Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

In Program Finder, the selected letter/number on the left, and program title (in the middle), and episode (right) are properly displayed enclosed in a round-ended 'focus' bar. The selected column (letter or program or episode) is also highlighted (changes from white to yellow in most themes).

This was the situation on versions up to at least 20403. By version 20570 continuing to 20640 (today's latest), the focus bar and highlight do not line up. The focus bar is 'up' one line. The highlighted entry is below the bar.

For example, with the numeral '1' as the topmost visible entry in Program Finder, the focus bar is on '5', but '6' is highlighted, then '60 Minutes' selecting right from '6' and under the focus bar. The episodes list also commences under the focus bar. The only way to select an episode is to use the 'information' menu key, as 'enter' (as a selection) selects nothing.

*Looks like* an 'index-off-by-one' error.

None of the commits between 20403 and 20570 jump out as affecting this, except possibly 20414.

Themes tried include Titivillus, Iulius and Mythcenter: no change. My setup uses VDPAU which is referred to in 20414.

Change History (8)

comment:1 Changed 10 years ago by stuartm

It's not a code error, just a theme alignment problem.

comment:2 in reply to:  1 Changed 10 years ago by anonymous

Replying to stuartm:

It's not a code error, just a theme alignment problem.

Do you (we) know which themes are a problem? Or is it a font size problem? Or what?

It is annoying. But not fatal!

Geoff

comment:3 Changed 10 years ago by stuartm

Just the default and default-wide themes. It's just that the coordinates for the list don't match up with the static highlight image.

comment:4 Changed 10 years ago by paulh

Component: MythTV - SchedulingMythTV - User Interface Library
Owner: changed from bjm to paulh
Status: newassigned

I'd fix it if I could see what the problem is :-) Oddly everything looks fine here. Any chance of a screenshot.

comment:5 Changed 10 years ago by stuartm

Paul it's a too many list items thing, thanks to the loss of pixel precision when scaling for higher/lower resolutions it's able to squeeze 10 items into the list instead of 9, so the centre item is no longer #5, it's #6 which is below the highlight box. Reducing the height of the list by 20 pixels or something should be enough to ensure only 9 items will fit.

comment:6 Changed 10 years ago by paulh

Resolution: fixed
Status: assignedclosed

(In [20649]) Reduce the size of the lists on the progfinder screen so there is just enough room for 9 items plus a little leeway. Fixes #6585.

comment:7 in reply to:  6 ; Changed 10 years ago by anonymous

Replying to paulh:

(In [20649]) Reduce the size of the lists on the progfinder screen so there is just enough room for 9 items plus a little leeway. Fixes #6585.

Wow! That was fast! Thanks! I will pull 20649+ tonight or tomorrow morning, test and report.

Geoff

comment:8 in reply to:  7 Changed 10 years ago by R. Geoffrey Newbury <newbury@…>

Replying to anonymous:

Wow! That was fast! Thanks! I will pull 20649+ tonight or tomorrow morning, test and report.

Tested with 20650 and the problem is fixed. Thanks! Geoff

Note: See TracTickets for help on using tickets.