Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6586 closed defect (invalid)

Mythweb Repeatedly crashes

Reported by: tortise@… Owned by: xris
Priority: major Milestone: 0.21.1
Component: Plugin - MythWeb Version: unknown
Severity: medium Keywords: mythweb
Cc: Ticket locked: no

Description

Browsing to /mythweb/status fails repeatedly with message below displayed instead. Backend is still running fine. BE details attached using the NVIDIA bug report.

Attachments (2)

tortise.txt (7.9 KB) - added by tortise 10 years ago.
Browser contents displayed instead of status
nvidia-bug-report.log (73.9 KB) - added by tortise 10 years ago.
System Description, c\o NVIDIA

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by tortise

Attachment: tortise.txt added

Browser contents displayed instead of status

Changed 10 years ago by tortise

Attachment: nvidia-bug-report.log added

System Description, c\o NVIDIA

comment:1 Changed 10 years ago by tortise

Sorry mythtv version is 0.21.20080304-1 18722 and not 0.21.1 as initially reported

comment:2 Changed 10 years ago by Rob Smith

Resolution: invalid
Status: newclosed

Mythweb is a different version then your backend. They have to be the same version.

comment:3 Changed 10 years ago by tortise

From Synaptic mythweb is also 0.21.0+fixes18722-0ubuntu1 All others reported there as same version. Can post screendump if sought. Should this be re-opened?

comment:4 Changed 10 years ago by anonymous

No, as something isn't right, the line: Unexpected response to MYTH_PROTO_VERSION 'MYTH_PROTO_VERSION 40': tells us that mythweb talked to the backend and it returned protocol version 40 and mythweb didn't understand that version, because it's expecting a higher or lower version. Submit the bug upstream to your packagers if they are the same package version.

comment:5 Changed 10 years ago by tortise

I have found this is caused and reproduced by simply crashing a frontend, e.g. killing the FE process sends the BE into this state, the backend process continues, but becomes largely unresponsive. I think testing various vdpau frontends that crashed (repeatedly!) is what caused this BE problem. It has nothing to do with different versions as the box has been (relatively) stable for about a year and continues to be stable so long as the FE does not crash. I post for clarification and completeness and in case this helps anyone. As the BE is now such an old version this may well have been addressed in later revisions. I'll test this when I have a later BE version running, but I expect said test has already been run many times by others running later versions.

Note: See TracTickets for help on using tickets.