Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#66 closed enhancement (duplicate)

Add a line edit virtual keyboard that you can use with the remote.

Reported by: jkondis <jkondis@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.18.1
Severity: low Keywords: virtual keyboard line edit
Cc: Ticket locked: no

Description

Use a virtual keyboard for Myth line edit boxes that allows for filling in settings, etc., without having a keyboard attached.

Attachments (7)

virtual_keyboard.patch (33.2 KB) - added by jkondis <jkondis@…> 14 years ago.
Provides a virtual keyboard for line edits for 0.18.x.
virtual_keyboard_font_palette.patch (33.3 KB) - added by jkondis <jkondis@…> 14 years ago.
This replaces the previous patch - it adds palette and font support, which I had forgotten to do before.
virtual_keyboard_key_space.patch (33.3 KB) - added by jkondis <jkondis@…> 14 years ago.
Oops - my apologies. - previous patches don't capture key_space - this fixes that. Please disregard previous 2 patches.
virtual_keyboard_fix_keys.patch (34.1 KB) - added by jkondis <jkondis@…> 14 years ago.
Changes keyPressEvent to use translated keypresses instead of checking for keys themselves. This is the proper way. Please disregard earlier patches for the virtual keyboard.
virtual_keyboard_mouse_handle.patch (34.8 KB) - added by anonymous 14 years ago.
Fix mouse handling when popup is active - use this instead of previous vk patches.
virtual_keyboard_fix_keyboard_keys.diff (35.1 KB) - added by jkondis <jkondis@…> 14 years ago.
Fixes some weirdness discovered if you use the keyboard while using the virtual keyboard. Can ignore all previous diffs.
virtual_keyboard_v2.diff (43.4 KB) - added by Paul mythtv@… 14 years ago.
Updates the last version to also work with MythRemoteLineEdit? and UIRemoteEditType

Download all attachments as: .zip

Change History (12)

Changed 14 years ago by jkondis <jkondis@…>

Attachment: virtual_keyboard.patch added

Provides a virtual keyboard for line edits for 0.18.x.

comment:1 Changed 14 years ago by jkondis <jkondis@…>

To use, hit OK/Select (enter) while a line edit is focused. Can be turned on/off in Utilities/Setup?->Setup->Appearance->QT. (Off preserves the old behavior.) Supports French, German, Greek, Italian, Spanish, and English (US or UK, depending on env. "LANG" variable) keyboard layouts, as well as the Compose key. More layouts are forthcoming (for the time being, my system doesn't display Katakana and Hiragana unicode properly). Should be ported to use the new upcoming mythui as time permits.

Changed 14 years ago by jkondis <jkondis@…>

This replaces the previous patch - it adds palette and font support, which I had forgotten to do before.

Changed 14 years ago by jkondis <jkondis@…>

Oops - my apologies. - previous patches don't capture key_space - this fixes that. Please disregard previous 2 patches.

comment:2 Changed 14 years ago by jkondis <jkondis@…>

Sorry for all the messages - this should be it. To work right, virtual keyboard currently requires that you have UP, DOWN, LEFT, RIGHT, SELECT, PLAY, and EXIT mapped to the following keys respectively: cursor-up, cursor-down, cursor-left, cursor-right, enter, space, and escape.

Changed 14 years ago by jkondis <jkondis@…>

Changes keyPressEvent to use translated keypresses instead of checking for keys themselves. This is the proper way. Please disregard earlier patches for the virtual keyboard.

Changed 14 years ago by anonymous

Fix mouse handling when popup is active - use this instead of previous vk patches.

comment:3 Changed 14 years ago by Isaac Richards

Resolution: duplicate
Status: newclosed

Duplicate of #27 - uses Qt for drawing, which can't be used going forward.

Changed 14 years ago by jkondis <jkondis@…>

Fixes some weirdness discovered if you use the keyboard while using the virtual keyboard. Can ignore all previous diffs.

Changed 14 years ago by Paul mythtv@…

Attachment: virtual_keyboard_v2.diff added

Updates the last version to also work with MythRemoteLineEdit? and UIRemoteEditType

comment:4 Changed 14 years ago by Paul mythtv@…

I've modified this patch to work with the MythRemoteLineEdit? and the UIRemoteEditType as well as the normal QLineEdit. Also converts many tabs to spaces.

I like this a lot. It doesn't stop you from using a normal keyboard if you want but also allow you to enter small amounts of text using a remote with only the up, down, left, right and select keys. It also works OK if you have a remote like the Sky Navigator with a built in keyboard. I think it is a very user friendly way of entering text and also caters for languages other than English.

If the only bar from getting this patch applied is the fact it uses QT widgets I will spend some time converting it to use the native uitypes. Is anyone working on this already?

Paul

comment:5 Changed 14 years ago by Isaac Richards

Yup, only bar is that it was using the Qt widgets.

Note: See TracTickets for help on using tickets.