Opened 11 years ago

Closed 11 years ago

#6601 closed defect (fixed)

MythWeb program detail link problem after schedule is created

Reported by: otto at kolsi dot fi Owned by: xris
Priority: minor Milestone: unknown
Component: Plugin - MythWeb Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

There is following problem when scheduling recordings through MythWeb. This has been working earlier but got broken maybe 1-2 months ago (android/iphone changes?).

When program is selected from the program listing, the following program details page section "More:" has "Back to the program listing" as a last link. When program schedule is created and this program detail page is reloaded, the link changes to "Back to recording schedules" -link.

This makes it impossible to jump back to program listings once a program has been scheduled.

Some other elements of the reloaded page are also wrong (green rectangle around program title is missing etc.).

Change History (2)

comment:1 Changed 11 years ago by otto at kolsi dot fi

Bit more details for this one. When this problem occurs (which is always) and new recording schedule is created and page is reloaded, MythWeb goes to page with this kind of URL:

http://192.168.11.4/mythweb/tv/detail?recordid=1436

This is the Recording Schedule view or page. Instead of that, the page which should have been shown is the Program Details page which has URL like this:

http://192.168.11.4/mythweb/tv/detail/1004/1246742100

So the problem is that after a program is scheduled for recording, the following page is the recording schedule page and not the updated program details page.

comment:2 Changed 11 years ago by Rob Smith

Resolution: fixed
Status: newclosed

This should be fixed now, we block on the scheduler

Note: See TracTickets for help on using tickets.