Opened 11 years ago

Closed 9 years ago

#6611 closed patch (fixed)

HD-PVR Signal Monitor

Reported by: jppoet@… Owned by: jpoet
Priority: minor Milestone: unknown
Component: MythTV - Recording Version: unknown
Severity: medium Keywords: HD-PVR Signal Monitor
Cc: beirdo Ticket locked: no

Description

Add a signal monitor for the HD-PVR recorder.

By using a signal monitor, we can eliminate some hard-coded sleeps and make the HD-PVR slightly more responsive.

Attachments (4)

hdpvr-signalmonitor.patch (9.1 KB) - added by jppoet@… 11 years ago.
HD-PVR signal monitor
hdpvr-signalmonitor-v2.patch (10.5 KB) - added by jppoet@… 10 years ago.
compatible with #6719
hdpvr-signalmonitor-v2.1.patch (11.5 KB) - added by jpoet 10 years ago.
Updated for r23670
hdpvr-signalmonitor-trunk-25379.patch (10.1 KB) - added by jpoet 9 years ago.
Updated for trunk r25379

Download all attachments as: .zip

Change History (20)

Changed 11 years ago by jppoet@…

Attachment: hdpvr-signalmonitor.patch added

HD-PVR signal monitor

comment:1 Changed 10 years ago by anonymous

I applied this patch and the first recording I made, which was SD, was recording at a much higher data rate than before. After that, I did back out this change since it is a "nice to have" but not required for my setup. I really like the idea of this patch.

Changed 10 years ago by jppoet@…

compatible with #6719

comment:2 Changed 10 years ago by jppoet@…

New version of patch with some enhancements and compatibility with #6719.

comment:3 Changed 10 years ago by ryan.goat@…

hdpvr-signalmonitor-v2.patch does not apply cleanly to trunk SVN 20924. There are issues with the file /libs/libmythtv/signalmonitor.cpp

comment:4 Changed 10 years ago by jppoet@…

#6719 with hdpvr-signalmonitor-v2.patch applies just fine against trunk 20924. Make sure you are applying hdpvr-signalmonitor-v2.patch after #6719 and not before.

comment:5 Changed 10 years ago by r.d.vaughan@…

As of SVN r21591 these HDPVR patches have issues:

Patches "channel-thread-v1.2.patch" and "hdpvr-signalmonitor-v2.patch" both have failed hunks.

I tried applying "channel-thread-v1.2.patch" first as instructed. These patches have worked for me for several weeks, up until r21591.

comment:6 Changed 10 years ago by jppoet@…

I have updated #6719 to fix the failed hunk. I don't see a failed hunk caused by this patch, though.

comment:7 Changed 10 years ago by r.d.vaughan@…

Thanks the update to #6719 resolved all failed hunk issues.

comment:8 Changed 10 years ago by databubble

As of SVN r21612, I'm getting two failed hunks in this patch. That's after applying #6179 successfully. Clean trunk, with only patches #5251, #6602, #6655, and #6179 applied.

comment:9 Changed 10 years ago by databubble

I removed #6655 (which has not been marked invalid) and this patch now applies cleanly.

Changed 10 years ago by jpoet

Updated for r23670

comment:10 Changed 10 years ago by jpoet

Updated for r23670

comment:11 Changed 10 years ago by jpoet

Component: MythTV - GeneralMythTV - Recording
Owner: changed from Isaac Richards to danielk
Status: newassigned

comment:12 Changed 10 years ago by ran nachmany

I have just applied and tested 6611, 602 and 6719 against trunk while using hdpvr with firmware 1.5.6.1. Livetv improved dramatically.

comment:13 Changed 9 years ago by beirdo

Cc: beirdo added

Changed 9 years ago by jpoet

Updated for trunk r25379

comment:14 Changed 9 years ago by jpoet

(In [25544]) Use a signal monitor for the HD-PVR to determine when the device is ready to record. Refs #6611

comment:15 Changed 9 years ago by danielk

Owner: changed from danielk to jpoet

comment:16 Changed 9 years ago by jpoet

Resolution: fixed
Status: assignedclosed

Fixed by [25544]

Note: See TracTickets for help on using tickets.