Opened 10 years ago

Closed 10 years ago

#6613 closed defect (wontfix)

dbox2 wont work at svn trunk 20683

Reported by: maik.wunder@… Owned by: Isaac Richards
Priority: minor Milestone: 0.23
Component: MythTV - Recording Version: head
Severity: medium Keywords: dbox2, livetv, recording
Cc: Ticket locked: no

Description

Hi all, i think we have a problem with the DBOX2 in latest SVN. EIT grabing works fine, but if i want to record from or to switch to liveTV to a dbox channel the frontend crashes. Backend-log:

2009-06-09 15:42:09.033 TVRec(7): HW Tuner: 7->7 2009-06-09 15:42:09.125 AutoExpire?: CalcParams?(): Max required Free Space: 2.0 GB w/freq: 15 min 2009-06-09 15:42:10.004 DBox2Rec(7): Waiting for request to finish... 2009-06-09 15:42:11.002 DBox2Rec(7): Waiting for request to finish... 2009-06-09 15:42:12.004 DBox2Rec(7): Waiting for request to finish... 2009-06-09 15:42:13.003 DBox2Rec(7): Waiting for request to finish... 2009-06-09 15:42:14.003 DBox2Rec(7): Waiting for request to finish... 2009-06-09 15:42:15.004 DBox2Rec(7): Waiting for request to finish... 2009-06-09 15:42:16.002 DBox2Rec(7): Waiting for request to finish... 2009-06-09 15:42:16.392 TVRec(7): Changing from Watching WatchingLiveTV to None 2009-06-09 15:42:16.393 Unknown type, recording height was 0 2009-06-09 15:42:16.398 DBox2Rec(7): Channel changing. Closing current stream... 2009-06-09 15:42:16.398 DBox2Rec(7) Error: HTTP Request failed! 2009-06-09 15:42:16.401 Finished recording Raumschiff Enterprise - Das nächste Jahrhundert: channel 27512

Frontend-Log: 2009-06-09 15:45:32.386 TV: ITVRestart done 2009-06-09 15:45:32.459 Video timing method: SGI OpenGL 2009-06-09 15:45:34.442 AFD: Opened codec 0x961bc30, id(MPEGVIDEO_VDPAU) type(Video) 2009-06-09 15:45:34.442 AFD: codec MP3 has 2 channels 2009-06-09 15:45:34.442 AFD: Opened codec 0x961bfa0, id(MP3) type(Audio) 2009-06-09 15:45:34.601 Opening audio device '/dev/dsp'. ch 2(2) sr 48000 2009-06-09 15:45:34.601 Opening OSS audio device '/dev/dsp'. 2009-06-09 15:45:34.608 NVP(0): Enabling Audio 2009-06-09 15:45:39.079 ~OpenGLVideoSync() -- closing opengl vsync 2009-06-09 15:45:39.496 Using protocol version 45 2009-06-09 15:45:46.127 RingBuf?(/mythtv/liveTV/27512_20090609154539.mpg): Invalid file (fd -1) when opening '/mythtv/liveTV/27512_20090609154539.mpg'. 2009-06-09 15:45:46.170 RingBuf?(/mythtv/liveTV/27512_20090609154539.mpg) Error: Invalid file descriptor in 'safe_read()'

hope you can help me, and sorry about my english.....

Regards, Maik

Change History (4)

comment:1 Changed 10 years ago by laga

Status: newinfoneeded_new

Does the frontent catch a segmentation fault? If so, please provide a backtrace. See these URLs for more information: http://www.mythtv.org/wiki/Debugging
http://www.mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2

comment:2 Changed 10 years ago by anonymous

No, there is no segfault from Frontend or even the backend. The Backend produces many error messages like: 2009-06-09 15:42:15.004 DBox2Rec(7): Waiting for request to finish...

and the Frontend like: RingBuf??(/mythtv/liveTV/27512_20090609154539.mpg): Invalid file (fd -1) when opening '/mythtv/liveTV Error: Invalid file descriptor in 'safe_read()'

After a few minutes the frontend goes back to the main menu. Thereafter watching liveTV from DVB-T ( Nova 500T ) or DVB-C ( Cablestar HD2 ) is possible.

I have reinstalled the 0.21-fixes version and my dBox runs fine again. So it seems that the problem is in 0.22...

Want to say that i'm using Mythtv since one year and i love it!

Maik

comment:3 Changed 10 years ago by laga

Milestone: 0.220.23
Priority: majorminor
Status: infoneeded_newnew

Okay. We'll need to push this issue back to 0.23. The DBox2 recorder is unmaintained - there's no active developer using a DBox2 - and might even be dropped soon.

If you can come up with a patch (and/or want to maintain it, including the port of the recorder to qt4 etc), that would be appreciated.

comment:4 Changed 10 years ago by danielk

Resolution: wontfix
Status: newclosed

DBox2 support is gone.

Note: See TracTickets for help on using tickets.