Opened 11 years ago

Closed 10 years ago

#6614 closed patch (duplicate)

Live TV doesn't respect Input Groups

Reported by: stichnot@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - Recording Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I have 6 tuners. Tuners 1-4 are HDHRs. Tuner 5 is an HD-PVR and tuner 7 is a PVR-150. Tuners 5 and 7 share the same STB input and so they are in their own input group. My preferences are set up so that live TV first tries tuner 7 and then tries lower-numbered tuners.

If I try to go to Live TV while tuner 5 is recording, it jumps straight to the main menu screen. Here is the frontend log:

2009-06-05 13:27:53.707 Using protocol version 40
2009-06-05 13:27:54.440 GetEntryAt(-1) failed.
2009-06-05 13:27:54.442 EntryToProgram(0@Wed Dec 31 16:00:00 1969) failed to get pginfo
2009-06-05 13:27:54.442 TV Error: LiveTV not successfully started
2009-06-05 13:27:54.442 TV Error: LiveTV not successfully started
2009-06-05 13:27:54.511 TV: Deleting TV Chain in destructor

And here is the backend log, running with "-v important,general,channel,record":

2009-06-05 13:27:53.696 Getting next free recorder after : -1
2009-06-05 13:27:53.697 Checking card 1. Best card so far 1
2009-06-05 13:27:53.698 Checking card 2. Best card so far 2
2009-06-05 13:27:53.699 Checking card 3. Best card so far 3
2009-06-05 13:27:53.700 Checking card 4. Best card so far 4
2009-06-05 13:27:53.703 Checking card 5. Best card so far 4
2009-06-05 13:27:53.704 Checking card 7. Best card so far 7
2009-06-05 13:27:53.707 MainServer::HandleAnnounce Playback
2009-06-05 13:27:53.912 adding: mythmaster as a client (events: 0)
2009-06-05 13:27:53.916 TVRec(7): Changing from None to WatchingLiveTV
2009-06-05 13:27:53.917 TVRec(7): ClearFlags(FrontendReady,CancelNextRecording,) -> RunMainLoop,
2009-06-05 13:27:53.918 TVRec(7): Request: Program(no) channel() input() flags(LiveTV,)
2009-06-05 13:27:53.920 TVRec(7): Start channel: 104.
2009-06-05 13:27:53.935 ChannelBase(7): IsTunable(S-Video 1,104) Requested channel is on input '7' which is in a busy input group
2009-06-05 13:27:53.936 ChannelBase(7): Looking for startchannel '104' on input 'S-Video 1'
2009-06-05 13:27:53.954 ChannelBase(7): IsTunable(S-Video 1,104) Requested channel is on input '7' which is in a busy input group
2009-06-05 13:27:53.975 ChannelBase(7) Error: Setting start channel '104' failed,
                        and we failed to find any suitible channels on any input.
2009-06-05 13:27:53.976 TVRec(7): HW Tuner: 7->7
2009-06-05 13:27:53.978 TVRec(7): ClearFlags(PENDINGACTIONS,) -> RunMainLoop,
2009-06-05 13:27:53.978 TVRec(7): No recorder yet, calling TuningFrequency
2009-06-05 13:27:53.988 Channel(/dev/video1): Device name 'Hauppauge WinTV PVR-150' driver 'ivtv'.
2009-06-05 13:27:54.186 ChannelBase(7): Input #7: 'S-Video 1' schan(104) sourceid(3) ccid(7)
2009-06-05 13:27:54.189 ChannelBase(7): Current Input #7: 'S-Video 1'
2009-06-05 13:27:54.190 Global TVFormat Setting 'NTSC'
2009-06-05 13:27:54.198 Channel(/dev/video1): Input #7: 'S-Video 1' schan(104) tun() v4l1(NTSC) v4l2(NTSC)
2009-06-05 13:27:54.206 Channel(/dev/video1): SetFormat(Default) fmt(NTSC) input(7)
2009-06-05 13:27:54.214 Channel(/dev/video1)::SwitchToInput(in 7, '')
2009-06-05 13:27:54.236 TVRec(7) Error: Failed to set channel to 104. Revertingto kState_None
2009-06-05 13:27:54.237 TVRec(7): Changing from WatchingLiveTV to None
2009-06-05 13:27:54.421 TVRec(7): ClearFlags(FrontendReady,CancelNextRecording,) -> RunMainLoop,
2009-06-05 13:27:54.422 TVRec(7): Request: Program(no) channel() input() flags(KillRec,KillRingBuffer,)
2009-06-05 13:27:54.423 TVRec(7): ClearFlags(PENDINGACTIONS,) -> RunMainLoop,
2009-06-05 13:27:54.431 TVRec(7): SetFlags(CancelNextRecording,) -> RunMainLoop,CancelNextRecording,

I attached a patch which fixes it at least for my setup, though I don't fully understand the schema so the patch may not be completely correct.

I am running 0.21-fixes (patched for VDPAU and HD-PVR).

$ mythbackend --version
Please include all output in bug reports.
MythTV Version   : 20549M
MythTV Branch    : branches/release-0-21-fixes
Library API      : 0.21.20080304-1
Network Protocol : 40
Options compiled in:
 linux release using_oss using_alsa using_backend using_dbox2
 using_dvb using_frontend using_hdhomerun using_iptv using_ivtv
 using_hdpvr using_joystick_menu using_lirc using_opengl_vsync
 using_opengl_video using_v4l using_x11 using_xrandr using_xv
 using_bindings_perl using_bindings_python using_opengl
 using_vdpau using_ffmpeg_threads using_live

Attachments (1)

livetv_inputgroups.patch (6.5 KB) - added by stichnot@… 11 years ago.

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by stichnot@…

Attachment: livetv_inputgroups.patch added

comment:1 Changed 10 years ago by Shane Shrybman

Resolution: duplicate
Status: newclosed
Version: unknownhead

Closed as a duplicate of #7123. Check #7123 for a test patch.

Thanks to stichnot for following up.

Note: See TracTickets for help on using tickets.