Opened 10 years ago

Closed 10 years ago

#6619 closed defect (fixed)

Watch Recordings group filter fails to display category contents.

Reported by: rafmoslin@… Owned by: Isaac Richards
Priority: minor Milestone: 0.22
Component: MythTV - General Version: head
Severity: low Keywords: Watch Recordings group filter
Cc: Ticket locked: no

Description

When changing the group filter from within the watch recordings screen to any of the categories causes no programs to be displayed.

Here is the a database trace from the point of selecting "Watch Recordings" to changing filter to "Animation", note that if I was then to ESC back one level and re-enter "Watch Recordings" I will then be prompted to select a filter view. I know that there is more here than needed but thought I would post the entire start to finish trace.

2009-06-10 17:50:48.365 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'ShortDateFormat?' AND hostname = 'vanguard' ;" 2009-06-10 17:50:48.366 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'DateFormat?' AND hostname = 'vanguard' ;" 2009-06-10 17:50:48.366 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'TimeFormat?' AND hostname = 'vanguard' ;" 2009-06-10 17:50:48.366 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'DisplayRecGroup?' AND hostname = 'vanguard' ;" 2009-06-10 17:50:48.367 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'PlayBoxOrdering?' AND hostname = 'vanguard' ;" 2009-06-10 17:50:48.367 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'PlaybackWLStart' AND hostname = 'vanguard' ;" 2009-06-10 17:50:48.368 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'PlaybackWLAutoExpire' AND hostname = 'vanguard' ;" 2009-06-10 17:50:48.369 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'PlaybackWLMaxAge' AND hostname = 'vanguard' ;" 2009-06-10 17:50:48.369 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'PlaybackWLBlackOut' AND hostname = 'vanguard' ;" 2009-06-10 17:50:48.370 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'DispRecGroupAsAllProg?' AND hostname = 'vanguard' ;" 2009-06-10 17:50:48.370 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'PreviewFromBookmark?' AND hostname = 'vanguard' ;" 2009-06-10 17:50:48.370 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'GeneratePreviewRemotely?' AND hostname = 'vanguard' ;" 2009-06-10 17:50:48.371 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'DisplayRecGroupIsCategory?' AND hostname = 'vanguard' ;" 2009-06-10 17:50:48.371 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'DisplayGroupDefaultViewMask?' AND hostname = 'vanguard' ;" 2009-06-10 17:50:48.371 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'PlaybackWatchList?' AND hostname = 'vanguard' ;" 2009-06-10 17:50:48.372 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'LiveTVInAllPrograms' AND hostname = 'vanguard' ;" 2009-06-10 17:50:48.372 MSqlQuery::exec() "SELECT recgroup, password FROM recgrouppassword WHERE password IS NOT NULL AND password <> ;" 2009-06-10 17:50:48.372 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'AllRecGroupPassword?' AND hostname = 'vanguard' ;" 2009-06-10 17:50:48.372 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'AllRecGroupPassword?' AND hostname IS NULL;" 2009-06-10 17:50:48.397 Loading window theme from /usr/local/share/mythtv/themes/default-wide/recordings-ui.xml 2009-06-10 17:50:48.397 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'QueryInitialFilter?' AND hostname = 'vanguard' ;" 2009-06-10 17:50:48.398 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'DisplayGroupTitleSort?' AND hostname = 'vanguard' ;" 2009-06-10 17:50:48.544 MSqlQuery::exec() "SELECT recordid,title FROM record WHERE search > 0 AND search != '5';" 2009-06-10 17:50:48.553 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'PlayBoxEpisodeSort?' AND hostname = 'vanguard' ;" 2009-06-10 17:50:48.554 MSqlQuery::exec() "SELECT recordid, type, maxepisodes, avg_delay, next_record, last_record, last_delete FROM record;" 2009-06-10 17:50:48.562 MSqlQuery::exec() "SELECT status FROM jobqueue WHERE type = '1' AND chanid = '8316' AND starttime = '2009-06-09T22:58:00';" 2009-06-10 17:50:48.562 MSqlQuery::exec() "SELECT status FROM jobqueue WHERE type = '2' AND chanid = '8316' AND starttime = '2009-06-09T22:58:00';" 2009-06-10 17:50:48.563 MSqlQuery::exec() "SELECT basename FROM recorded WHERE chanid = '8316' AND starttime = '2009-06-09T22:58:00';" 2009-06-10 17:50:48.563 MSqlQuery::exec() "SELECT DISTINCT dirname FROM storagegroup WHERE groupname = 'Default'" 2009-06-10 17:50:48.565 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'ChannelFormat?' AND hostname = 'vanguard' ;" 2009-06-10 17:50:48.565 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'LongChannelFormat?' AND hostname = 'vanguard' ;" 2009-06-10 17:50:48.695 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'PlaybackBoxStartInTitle?' AND hostname = 'vanguard' ;" 2009-06-10 17:50:48.738 MSqlQuery::exec() "SELECT status FROM jobqueue WHERE type = '1' AND chanid = '8316' AND starttime = '2009-06-09T22:58:00';" 2009-06-10 17:50:48.738 MSqlQuery::exec() "SELECT status FROM jobqueue WHERE type = '2' AND chanid = '8316' AND starttime = '2009-06-09T22:58:00';" 2009-06-10 17:50:48.739 MSqlQuery::exec() "SELECT status FROM jobqueue WHERE type = '1' AND chanid = '17832' AND starttime = '2009-06-09T22:28:00';" 2009-06-10 17:50:48.739 MSqlQuery::exec() "SELECT status FROM jobqueue WHERE type = '2' AND chanid = '17832' AND starttime = '2009-06-09T22:28:00';" 2009-06-10 17:50:48.739 MSqlQuery::exec() "SELECT basename FROM recorded WHERE chanid = '17832' AND starttime = '2009-06-09T22:28:00';" 2009-06-10 17:50:48.740 MSqlQuery::exec() "SELECT DISTINCT dirname FROM storagegroup WHERE groupname = 'Default'" 2009-06-10 17:50:48.741 MSqlQuery::exec() "SELECT status FROM jobqueue WHERE type = '1' AND chanid = '9384' AND starttime = '2009-06-09T20:59:00';" 2009-06-10 17:50:48.741 MSqlQuery::exec() "SELECT status FROM jobqueue WHERE type = '2' AND chanid = '9384' AND starttime = '2009-06-09T20:59:00';" 2009-06-10 17:50:48.742 MSqlQuery::exec() "SELECT basename FROM recorded WHERE chanid = '9384' AND starttime = '2009-06-09T20:59:00';" 2009-06-10 17:50:48.742 MSqlQuery::exec() "SELECT DISTINCT dirname FROM storagegroup WHERE groupname = 'Default'" 2009-06-10 17:50:48.743 MSqlQuery::exec() "SELECT status FROM jobqueue WHERE type = '1' AND chanid = '11216' AND starttime = '2009-06-09T19:59:00';" 2009-06-10 17:50:48.744 MSqlQuery::exec() "SELECT status FROM jobqueue WHERE type = '2' AND chanid = '11216' AND starttime = '2009-06-09T19:59:00';" 2009-06-10 17:50:48.744 MSqlQuery::exec() "SELECT basename FROM recorded WHERE chanid = '11216' AND starttime = '2009-06-09T19:59:00';" 2009-06-10 17:50:48.745 MSqlQuery::exec() "SELECT DISTINCT dirname FROM storagegroup WHERE groupname = 'Default'" 2009-06-10 17:50:48.746 MSqlQuery::exec() "SELECT status FROM jobqueue WHERE type = '1' AND chanid = '12306' AND starttime = '2009-06-08T20:58:00';" 2009-06-10 17:50:48.746 MSqlQuery::exec() "SELECT status FROM jobqueue WHERE type = '2' AND chanid = '12306' AND starttime = '2009-06-08T20:58:00';" 2009-06-10 17:50:48.746 MSqlQuery::exec() "SELECT basename FROM recorded WHERE chanid = '12306' AND starttime = '2009-06-08T20:58:00';" 2009-06-10 17:50:48.747 MSqlQuery::exec() "SELECT DISTINCT dirname FROM storagegroup WHERE groupname = 'Default'" 2009-06-10 17:50:48.748 MSqlQuery::exec() "SELECT status FROM jobqueue WHERE type = '1' AND chanid = '13866' AND starttime = '2009-06-08T19:59:00';" 2009-06-10 17:50:48.748 MSqlQuery::exec() "SELECT status FROM jobqueue WHERE type = '2' AND chanid = '13866' AND starttime = '2009-06-08T19:59:00';" 2009-06-10 17:50:48.749 MSqlQuery::exec() "SELECT basename FROM recorded WHERE chanid = '13866' AND starttime = '2009-06-08T19:59:00';" 2009-06-10 17:50:48.749 MSqlQuery::exec() "SELECT DISTINCT dirname FROM storagegroup WHERE groupname = 'Default'" 2009-06-10 17:50:48.751 MSqlQuery::exec() "SELECT status FROM jobqueue WHERE type = '1' AND chanid = '5351' AND starttime = '2009-06-07T23:19:00';" 2009-06-10 17:50:48.751 MSqlQuery::exec() "SELECT status FROM jobqueue WHERE type = '2' AND chanid = '5351' AND starttime = '2009-06-07T23:19:00';" 2009-06-10 17:50:48.751 MSqlQuery::exec() "SELECT basename FROM recorded WHERE chanid = '5351' AND starttime = '2009-06-07T23:19:00';" 2009-06-10 17:50:48.752 MSqlQuery::exec() "SELECT DISTINCT dirname FROM storagegroup WHERE groupname = 'Default'" 2009-06-10 17:50:48.753 MSqlQuery::exec() "SELECT status FROM jobqueue WHERE type = '1' AND chanid = '5351' AND starttime = '2009-06-07T22:56:00';" 2009-06-10 17:50:48.753 MSqlQuery::exec() "SELECT status FROM jobqueue WHERE type = '2' AND chanid = '5351' AND starttime = '2009-06-07T22:56:00';" 2009-06-10 17:50:48.754 MSqlQuery::exec() "SELECT basename FROM recorded WHERE chanid = '5351' AND starttime = '2009-06-07T22:56:00';" 2009-06-10 17:50:48.754 MSqlQuery::exec() "SELECT DISTINCT dirname FROM storagegroup WHERE groupname = 'Family Guy'" 2009-06-10 17:50:48.756 MSqlQuery::exec() "SELECT status FROM jobqueue WHERE type = '1' AND chanid = '12306' AND starttime = '2009-06-06T01:24:00';" 2009-06-10 17:50:48.757 MSqlQuery::exec() "SELECT status FROM jobqueue WHERE type = '2' AND chanid = '12306' AND starttime = '2009-06-06T01:24:00';" 2009-06-10 17:50:48.757 MSqlQuery::exec() "SELECT basename FROM recorded WHERE chanid = '12306' AND starttime = '2009-06-06T01:24:00';" 2009-06-10 17:50:48.757 MSqlQuery::exec() "SELECT DISTINCT dirname FROM storagegroup WHERE groupname = 'Default'" 2009-06-10 17:50:52.224 MSqlQuery::exec() "SELECT recgroup, COUNT(title) FROM recorded WHERE deletepending = 0 GROUP BY recgroup" 2009-06-10 17:50:52.228 MSqlQuery::exec() "SELECT DISTINCT category, COUNT(title) FROM recorded WHERE deletepending = 0 GROUP BY category" 2009-06-10 17:50:52.241 Loading window theme from /usr/local/share/mythtv/themes/default/recordings-ui.xml 2009-06-10 17:50:54.506 MSqlQuery::exec() "SELECT recordid,title FROM record WHERE search > 0 AND search != '5';" 2009-06-10 17:50:54.507 SortedList? is Empty 2009-06-10 17:50:54.507 MSqlQuery::exec() "SELECT data FROM settings WHERE value = 'RememberRecGroup?' AND hostname = 'vanguard' ;" 2009-06-10 17:50:54.508 MSqlQuery::exec() "DELETE FROM settings WHERE value = 'DisplayRecGroup?' AND hostname = 'vanguard' ;" 2009-06-10 17:50:54.508 MSqlQuery::exec() "INSERT INTO settings (value,data,hostname) VALUES ( 'DisplayRecGroup?', 'Animation [23 items]', 'vanguard' );" 2009-06-10 17:50:54.508 Clearing Settings Cache for 'DisplayRecGroup?'. 2009-06-10 17:50:54.508 Clearing Settings Cache. 2009-06-10 17:50:54.508 MSqlQuery::exec() "DELETE FROM settings WHERE value = 'DisplayRecGroupIsCategory?' AND hostname = 'vanguard' ;" 2009-06-10 17:50:54.509 MSqlQuery::exec() "INSERT INTO settings (value,data,hostname) VALUES ( 'DisplayRecGroupIsCategory?', '1', 'vanguard' );" 2009-06-10 17:50:54.509 Clearing Settings Cache. 2009-06-10 17:50:54.509 Clearing Settings Cache.

Change History (5)

comment:1 Changed 10 years ago by sphery <mtdean@…>

What listings provider are you using (xmltv grabber)? I'm pretty sure that categories are not specified by all providers. If your provider doesn't specify categories, filtering by category will not work. If you get vastly different numbers from the following, your listings/provider are the problem:

mysql -umythtv -p mythconverg \
-e "SELECT COUNT(*) AS 'Total programs' FROM program;" \
-e "SELECT COUNT(*) AS 'Programs with category' FROM program WHERE category IS NOT NULL;"

comment:2 Changed 10 years ago by sphery <mtdean@…>

Sorry, make that:

mysql -umythtv -p mythconverg \
-e "SELECT COUNT(*) AS 'Total programs' FROM program;" \
-e "SELECT COUNT(*) AS 'Programs with category' FROM program WHERE category != '';"

comment:3 Changed 10 years ago by rafmoslin@…

I'm sorry, should have added more detail originally, mea culpa. What I should have pointed out is that the individual categorys do say how many items are in that category, ie. in my case for example the following is a small part of what is shown in the filter selection dialog:

All Programmes [545 items] -- Groups -- Default [545 items] Deleted [16 items] -- Categories -- Animation [23 items] Comedy [36 items] Cookery [3 items] Current Affairs [1 items]

If I change the group view to include categories then the associated programs are shown. For completeness I've run an integrity check on the whole database, and did the count check you suggested. The totals from the program table is pretty much in line with what I would have expected, first result is 59527 and the second 42235. I assume the difference is due to having two cards, DVB-T and DVB-S and I the DVB-S 'uk_rt' xmltv grab sometimes fails (error 512).

And that is all I think I can add...

comment:4 Changed 10 years ago by paulh

Confirmed, I can see this bug also.

comment:5 Changed 10 years ago by paulh

Resolution: fixed
Status: newclosed

(In [20699]) Fix Watch Recordings group filter failing to display category contents. Fixes #6619.

Note: See TracTickets for help on using tickets.