Opened 10 years ago

Closed 10 years ago

#6622 closed defect (invalid)

Mythvideo fails to play file and subsequent attempts hang

Reported by: Damian O'Sullivan <damian@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When myth has been running for a while (perhaps a few hours) an attempt to play a video in mythvideo using myth proto fails (back to video info screen). A subsequent attemp to play hangs myth on the "Please wait..."

Attempt one : 2009-06-10 20:15:21.745 Found Image : myth://Videos@192.168.1.100:6543/TVSeries/Spooks/Season 7/folder.jpg : 2009-06-10 20:15:34.971 Could not find folder cover Image : 2009-06-10 20:15:39.429 Loading window theme from /usr/local/share/mythtv/themes/default-wide/video-ui.xml 2009-06-10 20:15:41.755 New DB connection, total: 2 2009-06-10 20:15:41.756 Connected to database 'mythconverg' at host: 192.168.1.100 2009-06-10 20:15:41.774 TV: Attempting to change from None to Watching Video 2009-06-10 20:15:49.237 MythSocket?(a31df50:46): readStringList: Error, timeout (quick). QString::arg: Argument missing: RemoteFile::openSocket(file data socket): Did not get proper response from /TVSeries/Spooks/Season 4/4x09 - Episode 9.avi:192.168.1.100, 6543 2009-06-10 20:15:49.237 RemoteFile::openSocket(file data socket): Did not get proper response from /TVSeries/Spooks/Season 4/4x09 - Episode 9.avi:192.168.1.100 2009-06-10 20:15:49.237 RemoteFile?(myth://Videos@192.168.1.100:6543/TVSeries/Spooks/Season 4/4x09 - Episode 9.avi) 2009-06-10 20:15:49.237 RingBuffer::RingBuffer?(): Failed to open remote file (myth://Videos@192.168.1.100:6543/TVSeries/Spooks/Season 4/4x09 - Episode 9.avi) => Second attempt 2009-06-10 20:15:55.261 TV: Attempting to change from None to Watching Video 2009-06-10 20:15:55.475 RemoteFile?(myth://Videos@192.168.1.100:6543/TVSeries/Spooks/Season 4/4x09 - Episode 9.avi) 2009-06-10 20:15:55.475 TV: StartPlayer?(0, Watching Video, main) -- begin 2009-06-10 20:15:56.583 RingBuf?(myth://Videos@192.168.1.100:6543/TVSeries/Spooks/Season 4/4x09 - Episode 9.avi): Taking too long to be allowed to read.. 2009-06-10 20:15:57.583 RingBuf?(myth://Videos@192.168.1.100:6543/TVSeries/Spooks/Season 4/4x09 - Episode 9.avi): Taking too long to be allowed to read.. 2009-06-10 20:15:58.583 RingBuf?(myth://Videos@192.168.1.100:6543/TVSeries/Spooks/Season 4/4x09 - Episode 9.avi): Taking too long to be allowed to read.. 2009-06-10 20:15:59.584 RingBuf?(myth://Videos@192.168.1.100:6543/TVSeries/Spooks/Season 4/4x09 - Episode 9.avi): Taking too long to be allowed to read.. 2009-06-10 20:16:00.637 RingBuf?(myth://Videos@192.168.1.100:6543/TVSeries/Spooks/Season 4/4x09 - Episode 9.avi): Taking too long to be allowed to read.. 2009-06-10 20:16:00.637 restarting readhead thread..

When I restart mythfrontend it plays correctly no problem.

damian@mythtv-box:~$ mythfrontend --version Please include all output in bug reports. MythTV Version : 20682M MythTV Branch : trunk Library API : 0.22.20090424-2 Network Protocol : 45 QT Version : 4.4.3 Options compiled in:

linux debug silent using_oss using_alsa using_arts using_jack using_backend using_directfb using_dvb using_firewire using_frontend using_hdpvr using_ivtv using_libfftw3 using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_opengl using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_libavc_5_3 using_mheg using_xvmc_pbuffer

Also I noticed when playing a long movie (greater than approx 1.5 hours) the OSD will stop working. ie. I can press exit and the movies pauses but I cannot select any option. Even guessing exit/resume/save options fails so myth is in essence hung. No standard log entries for this but thought it might be relevant. This is only happening in last week or so (I svn up and compile daily).

Any suggestions for debug let me know as it does seem an odd one.

Attachments (1)

myth_bug_6622.log (10.0 KB) - added by Damian O'Sullivan <damian@…> 10 years ago.
Updated log file with more verbose

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by Damian O'Sullivan <damian@…>

Attachment: myth_bug_6622.log added

Updated log file with more verbose

comment:1 Changed 10 years ago by Damian O'Sullivan <damian@…>

I saw this again today. Have included more verbose logs..

comment:2 Changed 10 years ago by dave.brueck@…

I'm experiencing this same bug on Ubuntu 9.10 beta frontend running against an Ubuntu 9.10 beta backend - I'll watch a recorded TV show just fine, and then when I go to play another show I get to the "Please wait..." screen and it just hangs. I let it sit for half an hour with no luck. The last few log lines are below, although they're nearly identical to the previously-posted ones so they probably don't help much:

2009-10-23 20:27:31.635 TV: Attempting to change from None to Watching WatchingPreRecorded? 2009-10-23 20:27:34.252 TV: StartPlayer?(0, Watching WatchingPreRecorded?, main) -- begin 2009-10-23 20:27:36.301 RingBuf?(/storage/myth/1057_20091016160000.mpg): Taking too long to be allowed to read.. 2009-10-23 20:27:37.301 RingBuf?(/storage/myth/1057_20091016160000.mpg): Taking too long to be allowed to read.. 2009-10-23 20:27:38.301 RingBuf?(/storage/myth/1057_20091016160000.mpg): Taking too long to be allowed to read.. 2009-10-23 20:27:39.302 RingBuf?(/storage/myth/1057_20091016160000.mpg): Taking too long to be allowed to read.. 2009-10-23 20:27:40.302 RingBuf?(/storage/myth/1057_20091016160000.mpg): Taking too long to be allowed to read.. 2009-10-23 20:27:40.303 restarting readhead thread..

No other messages are logged after that last line.

(/storage is an NFS mount to another Ubuntu box)

~$ mythfrontend.real --version Please include all output in bug reports. MythTV Version : MythTV Branch : tags/release-0-22-rc1 Network Protocol : 50 Library API : 0.22.20091008-1 QT Version : 4.5.2 Options compiled in:

linux profile using_oss using_alsa using_pulse using_jack using_backend using_dvb using_firewire using_frontend using_glx_proc_addr_arb using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_libavc_5_3 using_live using_mheg

comment:3 Changed 10 years ago by robertm

Status: newinfoneeded_new

Is this occurring with .23? If so, need frontend logs (as an attachment this time please) and backend logs with -v file.

comment:4 Changed 10 years ago by robertm

Resolution: invalid
Status: infoneeded_newclosed

No response.

Note: See TracTickets for help on using tickets.