Opened 10 years ago

Closed 10 years ago

#6653 closed patch (fixed)

segault in XvMCOSD::CreateBuffer after patch 20711

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Following patch 20711 I get a segfault in XvMCOSD::CreateBuffer? caused by changing XvShmCreateImage?() to use MythXDisplay* rather than Display*

Reverting this fixes the segfault. (trivial patch attached)

Attachments (1)

osdxvmc.cpp.diff (882 bytes) - added by anonymous 10 years ago.

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by anonymous

Attachment: osdxvmc.cpp.diff added

comment:1 Changed 10 years ago by markk

Resolution: fixed
Status: newclosed

(In [20738]) Fix segmentation fault in XvMC osd following r20711. Closes #6653.

Note: See TracTickets for help on using tickets.