Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#6666 closed defect (fixed)

Popups may not close if screen focus lost whilst popup is displayed

Reported by: Nick Morrott <knowledgejunkie <at> gmail <dot> com> Owned by: xris
Priority: minor Milestone: unknown
Component: Plugin - MythWeb Version: 0.21-fixes
Severity: medium Keywords: mythweb popup
Cc: Ticket locked: no

Description

When viewing the Upcoming Recordings listing (for example) it is possible for programme popups to remain stranded onscreen if the screen is interrupted whilst they are displayed. When this happens the only way to remove them is to relocate the programme link, reactivate the popup, and then mouseOut again.

Might it be possible to add a timer to close them automatically when focus has been lost for a certain amount of time?

Attachments (1)

mythweb_fixes_helptext.patch (1.8 KB) - added by Tom Dexter <digitalaudiorock@…> 11 years ago.
Main icon help text fix for 0.21-fixes

Download all attachments as: .zip

Change History (6)

comment:1 Changed 11 years ago by sphery <mtdean@…>

Fixed in trunk by [19387]

comment:2 Changed 11 years ago by Nick Morrott <knowledgejunkie (at) gmail (dot) com>

Grrr. Thanks a bunch for the heads up Mike. I've been up too long and didn't include changesets in my trac search for this. I'm guessing as it's part of the prototype work this won't find it's way into stable until 0.22 is released? I guess this can be closed - apologies for the noise.

(BTW - does trunk also fix the main icon mouseover problem in MythWeb - in that when you hover over an icon, the date/time field blanks instead of showing the associated text for the icon?)

comment:3 Changed 11 years ago by danielk

Resolution: fixed
Status: newclosed

comment:4 Changed 11 years ago by Tom Dexter <digitalaudiorock@…>

The issue with the main icon help text in 0.21-fixes (where the date/time gets hidden but no help text displays) is due to the fact that the help_text div hidden state is being initialized in css rather than in the actual html being sent to the browser. I believe this causes the hidden state in the css to get re-applied by the browser when it gets unhidden. It appears that trunk does correctly initialize it in the original html rather than in css, though much of that stuff has changed significantly. I'm attaching a patch for fixes that corrects this.

Changed 11 years ago by Tom Dexter <digitalaudiorock@…>

Main icon help text fix for 0.21-fixes

comment:5 Changed 11 years ago by Nick Morrott <knowledgejunkie (at) gmail (dot) com>

The attached patch from Tom completely fixes the problems I have been seeing. The lack of JS errors and having the required packages (standard Fedora builds) installed led me to believe there could still be an issue in the code - I'm afraid I'm not a strong enough Firebug user to have noticed the cause without a lot more time.

Thank you Tom for taking the time to debug this, and although 0.22 is coming soon, I hope it can be committed to -fixes to show at least my appreciation for your endeavours.

Cheers, Nick

Note: See TracTickets for help on using tickets.